Remove input.type and prospector.type fields that appear in Kibana's hits


#1

I'm using Filebeat to ingest some files into Logstash for data manipulation and thereafter indexed to Elasticsearch and displayed in Kibana. However I have fields such as input.type and prospector.type that has the "log" value appear in my Kibana hits which I do not want.

I've done some research and found out that they were generated as part of Filebeat. I've followed some of the solutions online, such as setting fields_under_root in filebeat.yml to false but to no avail. Anyone here able to help me with this? Thanks!

image


(Andrew Cholakian) #2

@dx123 I think what you're looking for is the drop_fields processor in beats.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.