Remove setting from indices


(kevins) #1

I accidentally created a new property on my indices called "
index.cluster.routing.allocation.disable_allocation"

Which, obviously, is not a real setting. How can I remove it? It's
confusing to others who are viewing it.

Thanks

Here is what it looks like:

  1. "settings": {
  2. "index.routing.allocation.disable_allocation": "false",
  3. "index.number_of_replicas": "1",
  4. "index.version.created": "900599",
  5. "index.number_of_shards": "5",
  6. "index.cluster.routing.allocation.disable_allocation": "false" <---
    want to remove this
  7. },

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0e914d2-d76c-427f-8865-15d5e4701ff8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jason Wee) #2

Hmm.. Kevin, have you know this already? I tried using curl -XDELETE to the
index setting api, won't work. Probably for now, by setting it to the
default in this example you given, false.

/Jason

On Wed, Dec 11, 2013 at 1:47 AM, Kevin S kevinsteger@gmail.com wrote:

I accidentally created a new property on my indices called "
index.cluster.routing.allocation.disable_allocation"

Which, obviously, is not a real setting. How can I remove it? It's
confusing to others who are viewing it.

Thanks

Here is what it looks like:

  1. "settings": {
  2. "index.routing.allocation.disable_allocation": "false",
  3. "index.number_of_replicas": "1",
  4. "index.version.created": "900599",
  5. "index.number_of_shards": "5",
  6. "index.cluster.routing.allocation.disable_allocation": "false" <---
    want to remove this
  7. },

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d0e914d2-d76c-427f-8865-15d5e4701ff8%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHO4itymmtH5E-hdq2f2hnbo80oXazPm%3DOEjSZy1Ly3614%3DwOg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3