Replication between nodes on different subnets


(Ben Ryan) #1

Hi,
I have got replication working between two nodes on different machines in
the same subnet but if I try to add a node that is on a machine on a
different subnet I get "falied to send join request to master" the reason
stated is Timeout waiting for task.

I have checked all the firewall settings and these are ok and netstat
shows connections on port 9300 between the two machines.

Is there anything else I can look at?

Config details:

Machine 1

cluster.name: bingo
node.master: true
network.bind_host: XXX.YYY.120.134
network.publish_host: XXX.YYY.120.134
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.multicast.enabled: false

Machine 2
cluster.name: bingo
node.master: true
network.bind_host: XXX.YYY.204.45
network.publish_host: XXX.YYY.204.45
transport.tcp.port: 9300
http.port: 9200
discovery.zen.ping.timeout: 10s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["XXX.YYY.120.134"]

XXX.YYY are the same on all machines.

Regards,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Drew Raines) #2

Ben Ryan wrote:

I have got replication working between two nodes on different
machines in the same subnet but if I try to add a node that is
on a machine on a different subnet I get "falied to send join
request to master" the reason stated is Timeout waiting for
task.

I have checked all the firewall settings and these are ok and
netstat shows connections on port 9300 between the two machines.

Is there anything else I can look at?

I assume you're starting machine 2 after machine 1?

The settings look right. I would double-check network
connectivity. From XXX.YYY.204.45, telnet XXX.YYY.120.134 9300
and make sure you get a connection.

Drew

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3