Restore line rendering in point series vis using percentile agg #35649

Hi Team,
I'm using
elasticsearch: 7.0.1
logstash: 7.0.1
kibana: 7.0.1

but kibana graph can't restore line in %tile graphs.

tried upgrading kibana to few version: like 7.2.x, 7.4.x, 7.12.x
none of them is compatible with elasticsearch: 7.0.1

Please help me to fix same, with existing ES version. I don't want to upgrade ES.

According to the issue, this has been fixed since 7.2 Can you elaborate on the steps you've taken and what exactly you are seeing being rendered?

Upgrade kibana version only, tried with 7.2.x , 7.4.x, 7.12.x


{"type":"log","@timestamp":"2021-05-17T11:55:02Z","tags":["status","plugin:rollup@7.4.2","info"],"pid":11797,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"This version of Kibana requires Elasticsearch v7.4.2 on all nodes. I found the following incompatible nodes in your cluster: v7.0.1 @ ("}
{"type":"log","@timestamp":"2021-05-17T11:55:23Z","tags":["security","error"],"pid":11797,"message":"Error registering Kibana Privileges with Elasticsearch for kibana-.kibana: [security_exception] current license is non-compliant for [security], with { license.expired.feature="security" }"}

NOTE: I don't want to upgrade ES version.

It's not possible to do this (also see GitHub - elastic/kibana: Your window into the Elastic Stack )

The fix for your issue is in a later version, so you need to upgrade your Elasticsearch cluster as well.

I see your current version is 7.0 - within the 7.x major release upgrades should be pretty smooth

thanks for update.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.