Reverting to previous version for just one node in the cluster

It looks like we upgraded one of the nodes in the cluster to higher version by mistake. This seems to be causing issues. I understand that you can't revert back to older version, especially given that lucene version was also updated. Hence, I was wondering how can we fix just one node (we always keep 2 replicas, so taking one node out might not be that big of a deal).

All nodes in the cluster have version: 5.3.2
New node has version: 5.4.0

Your help will be very much appreciated. Thank you.

Reverting is not supported. It might work though if absolutely nothing happened on the cluster in the meantime (no merge, no index operation, ...)

Why not upgrading all the nodes? And to 5.6 so you'll be almost ready for elasticsearch 6.0...

Upgrading all nodes to newer version might lead to more API work (we use elastic4s scala library).

  • Is there a way to check if there were no merge / index operations on the cluster?
  • If I just delete data (there are no unassigned shards) on the node with newer version and reboot the node with 5.3.2 version (to match other nodes), would that work?

I don't know for both questions.


FYI: I was able to delete data on node with version 5.4.2 and reboot with older version. Had to clean up a bunch of unassigned shards, but worked out well. Kind of scary to try this on production, but thankfully it worked. Thought of sharing it just in case it helps someone else.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.