Running Elastic as Wrong user


(Michael) #1

Hello, I have following message when running ElasticSearch through supervisorD program :

[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]

Therefore Elastic cannot start, I check my limits.conf file, it has the right configuration for my_user, but I cannot modify this file to add some conf for others users.

The thing is, if I run it manually in the terminal, elasticsearch run smoothly without the error,
How could I debug to understand why it would not run using the same user or configuration when run through supervisorD?


(Michael) #2

Furthermore, once launched,

If I run ps aux | grep elasticsearch,

I can see that my_user is the one runing the process,

So how could I have a difference when running it through supervisorD and manually..?


(675760585) #3

1.ps -ef|grep supervisord
2.kill -9 supervisord pid
3.start supervisord


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.