Running ELK stack with Enterprise Search using Docker on a server (Linux) invalid encryptions key

I use 1 docker-compose.yml file to run. On server I ran into

Custom Enterprise Search configuration file detected, not overwriting it (any settings passed via environment will be ignored)
Found java executable in PATH
Java version detected: 11.0.15 (major version: 11)
Enterprise Search is starting...
[2022-07-21T10:05:49.317+00:00][7][4004][app-server][INFO]: Elastic Enterprise Search version=8.3.1, JRuby version=9.3.3.0, Ruby version=2.6.8, Rails version=5.2.8
[2022-07-21T10:05:50.830+00:00][7][4004][app-server][ERROR]: 
--------------------------------------------------------------------------------

Invalid config file (/usr/share/enterprise-search/config/enterprise-search.yml):
The setting '#/secret_management/encryption_keys' is not valid
No secret management encryption keys were provided.
Your secrets cannot be stored unencrypted.
You can use the following generated encryption key in your config file to store new encrypted secrets:

secret_management.encryption_keys: [fc3a7394acc8835a60a45d4981801a088018d945e8e3cb8e577e85c0748f5606]


--------------------------------------------------------------------------------  

I don't even have enterprise search config file. I only set the config with environment in docker-compose.yml

I already set encryption keys in my .env file. I don't have this problem when running on my local using Docker (macOS).

I solved it by removing docker volume and running it again. If anyone knows the reason why this error would occur could be great.