Running Kibana-linux 6.0 (64bit) on AIX Machine

I am trying to run Kibana-linux 6.0 (64 bit) on AIX machine.

But "./kibana: ./../node/bin/node: 0403-006 Execute permission denied" is coming.
All R,W,X rights are provided to Kibana Folder.
But still same error is coming.

Please help.

Hi Preety,

We don't test or support Kibana on AIX, but I'll try to help you get it running. If you're in the Kibana directory can you see if the node executable works?

# node/bin/node -v

Are you logged in as the same user that owns the files in the Kibana directory?

I found one post by a user with a similar problem that found they had Symantec Critical Protection System that was causing a permission denied error.

This might be of some help;


Hi LeeDr

Thanks for the reply.

I have run Kibana from root directory and have checked all the rights to kibana folder.

But Still Same Error is Coming.

I am using latest version of Kibana 6.0 (64 bit) on AIX machine.
ELasticsearch 6.0 is running fine on AIX machine. But issue is with running Kibana.

Please help and revert.


just one thing, the kibana node binary usually is an X86 linux compiled one. So, most likely, you will have bad luck in trying to get it running.
The only other option I see is, if you can get node.js run on AIX platform at all, then exchange this AIX node.js with the one coming with kibana.... But as I said, the odds are most likely against you.

Best wishes,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.