Russian morphology plugin won't start on 2.1.1


(Max Just) #1

[2015-12-21 13:22:12,948][INFO ][node ] [index1] version[2.1.1], pid[1087], build[40e2c53/2015-12-15T13:05:55Z]
[2015-12-21 13:22:12,950][INFO ][node ] [index1] initializing ...
[2015-12-21 13:22:12,959][ERROR][bootstrap ] Exception
java.lang.IllegalArgumentException: Plugin [elasticsearch-analysis-morphology] is incompatible with Elasticsearch [2.1.1]. Was designed for version [2.1.0]
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:117)
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:302)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:108)
at org.elasticsearch.node.Node.(Node.java:146)
at org.elasticsearch.node.Node.(Node.java:128)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)


(nainy) #2

Nothing you can do about that, AFAIK.

If you want to use the plugin, use ES 2.1.0, or wait until the new version of the plugin is out.


(Max Just) #3

thank you, captain obvious :slight_smile:


(system) #4