Plugin is incompatible with Elasticsearch [2.1.0]. Was designed for version [2.0.0]


(Andrew Wooster) #1

I am upgrading my custom plugin (named magellan) from 2.0 to 2.1. But when I try to install the plug-in I get the following error:

-> Installing from file:/Users/Andrew/Source/Repos/Magellan/magellan-es-plugin/target/releases/magellan-es-plugin-1.0-SNAPSHOT.zip...
Trying file:/Users/Andrew/Source/Repos/Magellan/magellan-es-plugin/target/releases/magellan-es-plugin-1.0-SNAPSHOT.zip ...
Downloading ..................................................................................................................................................................................................................................................................................................................................................................................................DONE
Verifying file:/Users/Andrew/Source/Repos/Magellan/magellan-es-plugin/target/releases/magellan-es-plugin-1.0-SNAPSHOT.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: Plugin [magellan] is incompatible with Elasticsearch [2.1.0]. Was designed for version [2.0.0]

I recompiled using the 2.1 jar. I also converted my provider constructor signature from:

 @Inject
 public IndexTagAnalyzerProvider(Index index, @IndexSettings Settings indexSettings,
           Environment env, @Assisted String name, @Assisted Settings settings) throws IOException {
       super(index, indexSettings, name, settings);
  }

to

   @Inject
    public IndexTagAnalyzerProvider(Index index, IndexSettingsService indexSettingsService,
            @Assisted String name, @Assisted Settings settings) {
        super(index, indexSettingsService.indexSettings(), name, settings);
        analyzer.setVersion(version);
    }

Where can I find information on:

  • What changes do I need to make to a 2.0 plug-in to make it 2.1 compatible?
  • How to get more verbose debug from plug install? --verbose did not give me any more info.

(David Pilato) #2

You need to update the descriptor file as well.


(Andrew Wooster) #3

Thanks David. That was it. I forgot about the plugin-descriptor.properties file.


(system) #4