S3-repository deprecated settings warning

Hi,
I created a snapshot in ElasticSearch 5.4.3, according to https://www.elastic.co/guide/en/elasticsearch/plugins/current/repository-s3-repository.html , my cmd as below:

curl -XPUT 'http://localhost:9200/_snapshot/s3_repository' -d '{
    "type": "s3",
    "settings": {
        "access_key": "***",
        "secret_key": "***",
        "bucket": "es-snapshots",
        "region": "cn-north-1",
        "base_path": "Elasticsearch",
        "max_retries": 3
    }
}'

But ElasticSearch writes lots of WARNING logs out:

[2017-07-08T15:28:52,770][WARN ][org.elasticsearch.deprecation.common.settings.Setting] [region] setting was deprecated in Elasticsearch and will be removed in a future release! See the breaking changes documentation for the next major version.
[2017-07-08T15:28:52,771][WARN ][org.elasticsearch.deprecation.repositories.s3.InternalAwsS3Service] Specifying region for an s3 repository is deprecated. Use endpoint to specify the region endpoint if the default behavior is not sufficient.
[2017-07-08T15:28:52,773][WARN ][org.elasticsearch.deprecation.repositories.s3.InternalAwsS3Service] Using s3 access/secret key from repository settings. Instead store these in named clients and the elasticsearch keystore for secure settings.
[2017-07-08T15:28:52,787][WARN ][org.elasticsearch.deprecation.common.settings.Setting] [access_key] setting was deprecated in Elasticsearch and will be removed in a future release! See the breaking changes documentation for the next major version.
[2017-07-08T15:28:52,787][WARN ][org.elasticsearch.deprecation.common.settings.Setting] [secret_key] setting was deprecated in Elasticsearch and will be removed in a future release! See the breaking changes documentation for the next major version.

I wonder what's wrong with my operations, or the doc needs to be updated?

Doc needs an update.

You should start using endpoint instead.

You should also start using the keystore to store credentials.

https://www.elastic.co/guide/en/elasticsearch/reference/5.5/secure-settings.html#creating-keystore

Then add your secure settings as:

s3.client.default.access_key
s3.client.default.secret_key

See

And

I opened the following issue:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.