S3 Restore hanging on 6.4.2


(Mark Varley) #1

I have a fresh es 6.4.2 instance running on AWS on an i3.xlarge instance storing data on instance storage. I created an index, populated with data (around 30m records, only 2gb on disk) snapshotted successfully and then tried to restore to another cluster running exactly the same spec and build script, the restore operation starts successfully but then just hangs. As an experiment I deleted the original index on the first node and tried to restore from snapshot and experience exactly the same behaviour. There is nothing at all in the Elasticsearch logs to indicate that something bad has happened.

I have trawled the forums but can't find a solution. Any advice would be much appreciated.

ES Version:

version": {
"number": "6.4.2",
"build_flavor": "oss",
"build_type": "deb",
"build_hash": "04711c2",
"build_date": "2018-09-26T13:34:09.098244Z",
"build_snapshot": false,
"lucene_version": "7.4.0",
"minimum_wire_compatibility_version": "5.6.0",
"minimum_index_compatibility_version": "5.0.0"
},

Snapshot Status

{
   "snapshot": {
      "snapshot": "itl_clgavm_20181019",
      "uuid": "It9U8TC1TUSmi-x8q6gFEQ",
      "version_id": 6040299,
      "version": "6.4.2",
      "indices": [
         "itl_clgavm_20181019"
      ],
      "include_global_state": false,
      "state": "SUCCESS",
      "start_time": "2018-10-19T15:21:36.908Z",
      "start_time_in_millis": 1539962496908,
      "end_time": "2018-10-19T15:22:51.854Z",
      "end_time_in_millis": 1539962571854,
      "duration_in_millis": 74946,
      "failures": [],
      "shards": {
         "total": 1,
         "failed": 0,
         "successful": 1
      }
   }
}

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.