Script.painless.regex.enabled: true but ES log says it is not

ES 5.6.3

elasticsearch.yml has script.painless.regex.enabled: true

Caused by: java.lang.IllegalStateException: Regexes are disabled. Set [script.painless.regex.enabled] to [true] in elasticsearch.yaml to allow them. Be careful though, regexes break out of Painless's protection against deep recursion and long loops.

Now what?

Hi Jim,

Would you please attach your elasticsearch.yml file?


I figured it out. This is not a cluster setting, but an individual node setting. Thus, I had to add it to each node's elasticsearch.yml.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.