ScrutMyDocs : clearing previous install

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but
just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this
is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs,
but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this
is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

really much better, now I eliminated all traces of all index and
scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467
WARN [RiverService]
checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan
tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) :
Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at
org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the
server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025
DEBUG [AdminFSRiverService]
update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt,
*.html, *.pdf,
*.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing
is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs,
but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this
is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Once the river is created, you need to start it.
Look in the GUI or use REST API
curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here: https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

really much better, now I eliminated all traces of all index and scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467 WARN [RiverService] checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) : Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471 DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025 DEBUG [AdminFSRiverService] update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt, *.html, *.pdf, *.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I started it with the "start" button
in the settings screen
and it said it was started
is that not enough?

2013/7/7 David Pilato david@pilato.fr

Once the river is created, you need to start it.
Look in the GUI or use REST API

curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here:
https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

really much better, now I eliminated all traces of all index and
scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467
WARN [RiverService]
checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan
tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) :
Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at
org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the
server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025
DEBUG [AdminFSRiverService]
update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt,
*.html, *.pdf,
*.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing
is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs,
but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and
this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes. that's enough. There should be as far as I remember a green circle near the river name on the left.
So it should index documents.

Anything in logs?

Did you modify log level to TRACE?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 8 juil. 2013 à 21:57, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

I started it with the "start" button
in the settings screen
and it said it was started
is that not enough?

2013/7/7 David Pilato david@pilato.fr
Once the river is created, you need to start it.
Look in the GUI or use REST API
curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here: https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

really much better, now I eliminated all traces of all index and scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467 WARN [RiverService] checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) : Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471 DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025 DEBUG [AdminFSRiverService] update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt, *.html, *.pdf, *.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr
BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \




      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |




      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /



            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

it starts
that is ok

but it won't index the folder I pointed it to
it just will index another folder
one of the app folders

look at this again please

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

2013/7/8 David Pilato david@pilato.fr

Yes. that's enough. There should be as far as I remember a green circle
near the river name on the left.
So it should index documents.

Anything in logs?

Did you modify log level to TRACE?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 8 juil. 2013 à 21:57, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

I started it with the "start" button
in the settings screen
and it said it was started
is that not enough?

2013/7/7 David Pilato david@pilato.fr

Once the river is created, you need to start it.
Look in the GUI or use REST API

curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here:
https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

really much better, now I eliminated all traces of all index and
scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467
WARN [RiverService]
checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan
tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) :
Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at
org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the
server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025
DEBUG [AdminFSRiverService]
update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt,
*.html, *.pdf,
*.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing
is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs,
but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and
this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \




      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |




      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /



            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Did you modify log level to TRACE?
Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 8 juil. 2013 à 22:06, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

it starts
that is ok

but it won't index the folder I pointed it to
it just will index another folder
one of the app folders

look at this again please

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

2013/7/8 David Pilato david@pilato.fr
Yes. that's enough. There should be as far as I remember a green circle near the river name on the left.
So it should index documents.

Anything in logs?

Did you modify log level to TRACE?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 8 juil. 2013 à 21:57, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

I started it with the "start" button
in the settings screen
and it said it was started
is that not enough?

2013/7/7 David Pilato david@pilato.fr
Once the river is created, you need to start it.
Look in the GUI or use REST API
curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here: https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

really much better, now I eliminated all traces of all index and scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467 WARN [RiverService] checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) : Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471 DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025 DEBUG [AdminFSRiverService] update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt, *.html, *.pdf, *.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that everthing is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr
BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com a écrit :

Hi

I am trying to clear a previous install of ElasticSearch / ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \





      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |





      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /




            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \




      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |




      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /



            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Now, yes. Set log level to trace.

River will start, but will only get 4 docs, 2 called Notice and 2 called
License.
None of mine.

Any ideas?

Log follows (not long).


Got this:

[#|2013-07-11T03:57:16.099-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=90;_ThreadName=Thread-1;|03:57:16,077
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at
org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:94)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction.doExecute(TransportShardSingleOperationAction.java:71)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction.doExecute(TransportShardSingleOperationAction.java:46)
at
org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:61)
at org.elasticsearch.client.node.NodeClient.execute(NodeClient.java:92)
at
org.elasticsearch.client.support.AbstractClient.get(AbstractClient.java:179)
at
org.elasticsearch.action.get.GetRequestBuilder.doExecute(GetRequestBuilder.java:112)
at
org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:62)
at
org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:57)
at
org.scrutmydocs.webapp.service.settings.rivers.RiverService.checkState(RiverService.java:60)
at
org.scrutmydocs.webapp.service.settings.rivers.RiverService.start(RiverService.java:108)
at
org.scrutmydocs.webapp.service.settings.rivers.AdminRiverAbstractService.start(AdminRiverAbstractService.java:166)
at
org.scrutmydocs.webapp.configuration.AppPostProcessor.onApplicationEvent(AppPostProcessor.java:40)

and this:

[#|2013-07-11T04:12:52.535-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=93;_ThreadName=Thread-1;|04:12:52,482
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.action.NoShardAvailableActionException: [_river][0] No
shard available for [[_river][myfirstriver][_status]: routing [null]]
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.perform(TransportShardSingleOperationAction.java:139)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.start(TransportShardSingleOperationAction.java:124)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction.doExecute(TransportShardSingleOperationAction.java:71)

And then this:
(sorry for pasting here, but gist.github.com won't work tonight)

[#|2013-07-11T05:03:30.969-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=278;_ThreadName=Thread-1;|05:03:30,969
DEBUG [AdminFSRiverService]
update(FSRiver=[id="rivertiger",start=false,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:31.754-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=278;_ThreadName=Thread-1;|05:03:31,754
DEBUG [AdminFSRiverService]
/update(FSRiver=[id="rivertiger",start=false,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:35.524-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,524
DEBUG [AdminFSRiverService] get(rivertiger)
|#]

[#|2013-07-11T05:03:35.527-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,527
DEBUG [AdminFSRiverService]
/get(rivertiger)=FSRiver=[id="rivertiger",start=false,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"]
|#]

[#|2013-07-11T05:03:35.530-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,529
DEBUG [AdminFSRiverService]
start(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:35.533-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,533
DEBUG [RiverService]
add(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:35.535-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,535
DEBUG [RiverService]
createIndexIfNeeded(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:35.536-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,536
DEBUG [ESHelper] createIndexIfNeeded(docstiger, doctiger, standard)
|#]

[#|2013-07-11T05:03:35.537-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,537
DEBUG [ESHelper] Index docstiger doesn't exist. Creating it.
|#]

[#|2013-07-11T05:03:35.999-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:35,999
DEBUG [ESHelper] Mapping [docstiger]/[folder] doesn't exist. Creating it.
|#]

[#|2013-07-11T05:03:36.049-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,049
DEBUG [ESHelper] Mapping definition for [docstiger]/[folder] succesfully
created.
|#]

[#|2013-07-11T05:03:36.050-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,050
DEBUG [ESHelper] Mapping [docstiger]/[doctiger] doesn't exist. Creating it.
|#]

[#|2013-07-11T05:03:36.357-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,357
DEBUG [ESHelper] Mapping definition for [docstiger]/[doctiger] succesfully
created.
|#]

[#|2013-07-11T05:03:36.358-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,358
DEBUG [ESHelper] /createIndexIfNeeded()
|#]

[#|2013-07-11T05:03:36.359-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,359
DEBUG [RiverService]
/createIndexIfNeeded(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:36.363-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:36,363
DEBUG [RiverService]
checkState(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:37.366-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:37,366
DEBUG [RiverService]
checkState(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:38.388-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:38,388
DEBUG [RiverService]
/add(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:38.390-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:38,390
DEBUG [AdminFSRiverService]
/start(FSRiver=[id="rivertiger",start=true,excludes="",updateRate=5,typename="doctiger",name="rivertiger",analyzer="standard",type="fs",includes="*.html,
*.txt, *.pdf, *.doc",url="/home/m/text_files/",indexname="docstiger"])
|#]

[#|2013-07-11T05:03:48.643-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=187;_ThreadName=Thread-1;|05:03:48,643
DEBUG [SearchService] google('', 0, 10)
|#]

2013/7/8 David Pilato david@pilato.fr

Did you modify log level to TRACE?
Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 8 juil. 2013 à 22:06, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

it starts
that is ok

but it won't index the folder I pointed it to
it just will index another folder
one of the app folders

look at this again please

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

2013/7/8 David Pilato david@pilato.fr

Yes. that's enough. There should be as far as I remember a green circle
near the river name on the left.
So it should index documents.

Anything in logs?

Did you modify log level to TRACE?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 8 juil. 2013 à 21:57, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

I started it with the "start" button
in the settings screen
and it said it was started
is that not enough?

2013/7/7 David Pilato david@pilato.fr

Once the river is created, you need to start it.
Look in the GUI or use REST API

curl -XGET 'localhost:8080/scrutmydocs/api/1/settings/rivers/fs/myfirstriver/start

We create some sample docs you should remove here:
https://github.com/scrutmydocs/scrutmydocs/blob/master/src/main/java/org/scrutmydocs/webapp/configuration/AppPostProcessor.java#L34

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 juil. 2013 à 04:02, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

really much better, now I eliminated all traces of all index and
scrutmydocs, when given no search argument, brings no docs

  1. an exception in the log : no river

[#|2013-07-06T21:22:55.467-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,467
WARN [RiverService]
checkState(FSRiver=[id="myfirstriver",start=true,updateRate=30,typename="doc",name="Scan
tmp dir",analyzer="standard",type="fs",url="/tmp_es",indexname="docs"]) :
Exception raised : class org.elasticsearch.indices.IndexMissingException
|#]

[#|2013-07-06T21:22:55.486-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=11;_ThreadName=Thread-1;|21:22:55,471
DEBUG [RiverService] - Exception stacktrace :
org.elasticsearch.indices.IndexMissingException: [_river] missing
at
org.elasticsearch.cluster.metadata.MetaData.concreteIndex(MetaData.java:616)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:90)
at
org.elasticsearch.action.get.TransportGetAction.resolveRequest(TransportGetAction.java:42)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.(TransportShardSingleOperationAction.java:114)
at
org.elasticsearch.action.support.single.shard.TransportShardSingleOperationAction$AsyncSingleAction.

re-created the river:
http://postimg.org/image/tngpac1gt/

this is the first time the name of the river "autoriver" appears in the
server.log, it looks that this is the creation of the river

[#|2013-07-06T21:36:31.025-0300|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=25;_ThreadName=Thread-1;|21:36:31,025
DEBUG [AdminFSRiverService]
update(FSRiver=[id="autoriver",start=false,excludes=".mp4",updateRate=1,typename="autodoc",name="autoriver",analyzer="standard",type="fs",includes=".txt,
*.html, *.pdf,
*.doc",url="/usr/local/tiger/textfiles",indexname="autodocs"])
|#]

so it should index this:
http://postimg.org/image/t14nugafn/

but when I use it again with no search argument...
it bring some documents, but not what I was looking for...
http://postimg.org/image/osn8lw6i1/

you will surely recognize one of the docs that it shows...
http://postimg.org/image/5eoiuf7oj/

I have revised the process three or four times, and I find that
everthing is done as it should....

no other exceptions in server.log

Any help will be greatly appreciated.
Thanks in advance.

2013/7/6 Fatima Castiglione Maldonado 发 castiglionemaldonado@gmail.com

Great.

What would this list be without you?

2013/7/6 David Pilato david@pilato.fr

BTW a curl -XDELETE localhost:9200 should remove everything as well.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 19:14, David Pilato david@pilato.fr a écrit :

As far as I remember, data dir is in ~/.scrutmydocs/*

Check this one.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 juil. 2013 à 09:32, Fatima Castiglione Maldonado 发 <
castiglionemaldonado@gmail.com> a écrit :

Hi

I am trying to clear a previous install of ElasticSearch /
ScrutMyDocs, but just cannot. The good old index is there.

I have run a search for "elasticsearch" starting from root ( / ) and
this is the result:

http://postimg.org/image/g3ftwe2md/

What can I do ?
Is there anything else I can delete ?
Where else or what else may i search ?

Thanks in advance.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \





      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |





      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /




            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \




      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |




      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /



            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \



      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |



      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /


            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \


      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |


      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /

            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

_______|||
<
) .------.
-----------,------.-' ,-'-.

             |    |  |              ,'                `.
            ,'    |  |            ,'                    `.
            |  _,-'  |__         /                        \
          _,'-'    `.   `---.___|_____________             \

      .--'  -----.  | _____________________   `-. -----     |
      |    ___|  |  |                      \  ,- \          |
      |    ___|  |===========================((|) |         |
      |       |  |  | _____________________/  `- /          |

      `--._ -----'  |        _________________,-' -----     |
           `.-._   ,' __.---'   |                          /
            |   `-.  |           \                        /
            `.    |  |            `.                    ,'

             |    |  |              `.                ,'

_____,------------------. -._ _,-' <___________________________)------'
| _| |

               `.____|

=================================

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

Fátima Castiglione Maldonado
castiglionemaldonado@gmail.com

                 ____
               ,'_   |

|||
<
) .------.
-----------,------.-' ,-'-.
| | | ,' . ,' | | ,'.
| ,-' |
/
,'-' .---.|
_____
.--' -----. | _____________________ -. ----- | | ___| | | \ ,- \ | | ___| |===========================((|) | | | | | | _____________________/- / |
--._ -----' | _________________,-' ----- |.-._ ,' __.---' | /
| -. | \ /. | | . ,' | | |. ,'
_____,------------------. -._ _,-' <___________________________)------'
| | |
`.
___|

=================================

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.