Search.max_buckets limit error on 7.0.1

I have just upgraded to 7.0.1
now I get this error.

how do I change this value?

"Trying to create too many buckets. Must be less than or equal to: [10000] but was [10001]. This limit can be set by changing the [search.max_buckets] cluster level setting.","max_buckets":10000}},"status":503}

search.max_buckets is a cluster-level setting, so you can change it with the Update Cluster Settings API.

Do note that search.max_buckets is a safety soft-limit designed to prevent bad aggregations from hurting nodes. So be careful about making the limit too high. If you're tripping the limit often it might mean your aggregations need to be reconsidered or made smaller.

Thanks. found bad aggrigation, fixed it and error is gone

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.