Security is disabled but enabled in elasticsearch.yml

when i run elasticsearch in the console it shows that the security is disabled while i'm setting it to true in the elasticsearch.yml i'm also getting cors errors, so i'm starting to doubt that elasticsearch doesn't read my yaml file anymore: here's my yaml file:

#action.destructive_requires_name: true false true
http.cors.enabled: true
http.cors.allow-origin: "*"
http.cors.allow-methods: OPTIONS, HEAD, GET, POST, PUT, DELETE
http.cors.allow-headers: Authorization,X-Requested-With,X-Auth-Token,Content-Type,Content-    Length
http.cors.allow-credentials: true

thanks in advance!

Can you share the output of the following requests via curl:

  • GET _cluster/settings?include_defaults
  • GET /_xpack

Please conceal critical or sensitive text.

Also ensure you have a basic license installed.

thank you @Luca_Belluccini for your answer, the problem was solved by restarting the cmd and trying to run elasticsearch again, i think it was a bug since i didn't change anything in the configuration.

I might think of a misconfiguration.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.