Seem to be getting error when query on a long with field:>value


(Xamox) #1

So I've installed Elastic 2.1.0 and using topbeat 1.0.1 to post data. I'm basically just trying to query on cpu.system_p:>0.8, as I want to filter when it's above 80% usage. The issue is it throws a red bar with an error "discover: for input string...." but if I say don't use a long like cpu.system_p:>1 then it won't error out, except that obviously isn't returning the data I want. I've looked at the mappings (posted below) and they are longs. I've also tried wrapping the query as a string cpu.stream_p:">0.8" but that does not work either. Is it not possible to do what I'm trying to do? Or is my syntax just wrong?

I've tried this with kibana 4.3.1 as well as 4.4 branch from git but experience same results.

mappings can be found here:
https://gist.github.com/xamox/f9f3df56e7c614a94d68


(Mark Walkom) #2

Longs are really integers, in that they are whole numbers, so you cannot have/use decimals when querying them.


(Xamox) #3

Ahh, k. After playing with it some more it appears double mappings do work for query on greater or less than with something like >0.4. I suppose I could change the mappings if I need topbeat to function in that particular way. Thanks for the info.


(system) #4