Service States: No results found


I am working with metricbeat 7.7.0 , I enabled system module to monitor service status

  • module: system
    period: 10s
    • cpu
    • load
    • memory
    • network
    • process
    • process_summary
    • socket_summary
    • entropy
    • core
    • diskio
    • socket
    • service
      #- users
      by_cpu: 5 # include top 5 processes by CPU
      by_memory: 5 # include top 5 processes by memory

But I didn't see anything "No results found"

Are there any modifications to make ?
Could you please help ?

Hi @Kawther,

Let's try to find the source of this. Do you have any other metricbeat modules enabled? Do they work?

If this is the only module, do the value for the following fields on your metricbeat.yml look correct for your cluster?

  hosts: [....]
  username:  "..."
  password: "..."

Hello @afgomez, thank you for your response

Yes I have mongodb module enabled, and I have dashboard and data displayed correctly

My config:
#Array of hosts to connect to.
hosts: ["10.228.xx.xx:9200"]
#protocol: "https"
#Authentication credentials - either API key or username/password.
#api_key: "id:api_key"
#username: "elastic"

I still have the issue, could you please help ?

Hi @Kawther,

Could you confirm for me that systemd resource accounting is enabled? The system.service metricset will only work with that enabled. With a lot of distributions tasks and memory are the only things with resource accounting enabled by default.

If that's enabled and configured correctly, could you please paste an example of one of your system.service Metricbeat documents? (Please amend anything confidential).

You should be able to use a query similar to the following in Kibana's Dev Tools:

  GET metricbeat-*/_search
          "query": {
              "term": {"event.dataset": "system.service"}

Hello @Kerry, thank you for your response.

Please how can I check if the systemd resource accounting is enabed ?

This is the result of GET :
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 3,
"successful" : 3,
"skipped" : 0,
"failed" : 0
"hits" : {
"total" : {
"value" : 0,
"relation" : "eq"
"max_score" : null,
"hits" : [ ]

Thank you

@Kawther Okay - there's no matching documents in your cluster at all, so the empty dashboard is to be expected. This looks like a configuration issue.

Please how can I check if the systemd resource accounting is enabed ?

This varies between Linux distributions, and on how systemd has been setup (this isn't something Elastic controls). The systemd resource control documentation exists here, the options of interest have the suffix Accounting, e.g. CPUAccounting=. With one, or multiple, of these accounting features enabled the Metricbeat metricset should work.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.