setTimeout() of SearchRequestBuilder not working

Hi,

I have a query on method setTimeout() of SearchRequestBuilder. We have set a timeout value of 1 milliseconds while creating SearchRequestBuilder to execute the query. When we get the SearchResponse object and extract total time taken by executing the method getTookInMillis() of SearchResponse class, the total time comes as 100 milliseconds. That means query should have timed out as we have set time out value of 1 milliseconds earlier, still we are getting the result. It means that timeout value set in SearchRequestBuilder is not working.

When we check the docs for SearchRequestBuilder, it says that setTimeout() method allow us to set 'an optional timeout to control how long search is allowed to take'.

Can you please suggest if we are interpreting or doing something wrong!

Thanks.

This happens to me too; see this;

On Wednesday, April 17, 2013 5:27:01 AM UTC-4, Kranti wrote:

Hi,

I have a query on method setTimeout() of SearchRequestBuilder. We have set
a
timeout value of 1 milliseconds while creating SearchRequestBuilder to
execute the query. When we get the SearchResponse object and extract total
time taken by executing the method getTookInMillis() of SearchResponse
class, the total time comes as 100 milliseconds. That means query should
have timed out as we have set time out value of 1 milliseconds earlier,
still we are getting the result. It means that timeout value set in
SearchRequestBuilder is not working.

When we check the docs for SearchRequestBuilder, it says that setTimeout()
method allow us to set 'an optional timeout to control how long search is
allowed to take'.

Can you please suggest if we are interpreting or doing something wrong!

Thanks.

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/setTimeout-of-SearchRequestBuilder-not-working-tp4033517.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks for sharing the information.