Setting discovery.zen.ping.unicast.hosts for a server that is running


(kevins) #1

My server environment does not support multicast and I am trying to
construct a 2 node cluster on separate VM's. Both masters with data.

The elasticsearch that I am running is inside of a docker container.

What I would like to do is something like this:

Via the URL: http://localhost:9200/_custer/settings

{
"transient": {
"discovery.zen.ping.unicast.hosts": "x.x.x.1:9300, x.x.x.2:9300"
}
}

When I execute that with a PUT it does not stick. It simply reports back
an empty settings that looks like this:

{"persistent":{},"transient":{}}

I can execute other cluster settings that do work such as:

{
"transient": {
"indices.store.throttle.type": "merge",
"indices.store.throttle.max_bytes_per_sec": "1mb",
}
}

Question is: What is the best method for setting hosts in this particular
environment? Can the hosts be defined at runtime? I would prefer not to
set this as part of the container image that is used.

I launch elasticsearch with something that looks like this:

docker run -i -t -d -p 9200:9200 -p 9300:9300 ehazlett/elasticsearch

Thank you for any suggestions.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(John Goodall) #2

Did you figure this out - I am trying to do the same thing...

On Sunday, November 10, 2013 1:20:12 PM UTC-5, Kevin S wrote:

My server environment does not support multicast and I am trying to
construct a 2 node cluster on separate VM's. Both masters with data.

The elasticsearch that I am running is inside of a docker container.

What I would like to do is something like this:

Via the URL: http://localhost:9200/_custer/settings

{
"transient": {
"discovery.zen.ping.unicast.hosts": "x.x.x.1:9300, x.x.x.2:9300"
}
}

When I execute that with a PUT it does not stick. It simply reports back
an empty settings that looks like this:

{"persistent":{},"transient":{}}

I can execute other cluster settings that do work such as:

{
"transient": {
"indices.store.throttle.type": "merge",
"indices.store.throttle.max_bytes_per_sec": "1mb",
}
}

Question is: What is the best method for setting hosts in this
particular environment? Can the hosts be defined at runtime? I would
prefer not to set this as part of the container image that is used.

I launch elasticsearch with something that looks like this:

docker run -i -t -d -p 9200:9200 -p 9300:9300 ehazlett/elasticsearch

Thank you for any suggestions.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ed53157e-91c3-4abd-99cc-018288b5fadf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3