Setting dynamic mapping to false for root but enable it for selected fields

Hi all,

Currently, I am trying to index documents that have conflicting mapping.
ElasticSearch cannot resolve that, so I am trying to reverse the indexing

I have disabled dynamic mapping at the root, but I would like to explicitly
provide the mapping for some fields or have the dynamic mapping set to true
for some.

"mappings": {
"default": {
"dynamic" : "false",
"_all" : {"enabled" : true},
"properties" : {
"#text" : { "type": "string",
"dynamic" : "true"

However, it still won't index in this case the #text field. Have I
misunderstood how this feature works? Could someone please help me out?



You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit