Setting publish_address for logstash


(Sijo Mathew) #1

Hi,

The machine that I run logstash process has two network interfaces (public
and private) and it looks like the logstash process picks up my private IP
address as the "publish_address" by default. As I use the option "node", it
is not able to join the cluster as this address is not visible externally.
Master node is in a different network. Could someone suggest how can I
specifically set the publish address for the logstash process? I know this
option is available for the elastic search processes in its config file
(elasticsearch.yml) but not aware of how to set this for the logstash
process.

Thanks
Sijo Mathew

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b9fda42d-8036-4fbc-9fcb-e91dfce5ce1d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Sijo Mathew) #2

bind_host option did the trick!

On Thursday, April 2, 2015 at 3:39:10 PM UTC-4, mailsij...@gmail.com wrote:

Hi,

The machine that I run logstash process has two network interfaces (public
and private) and it looks like the logstash process picks up my private IP
address as the "publish_address" by default. As I use the option "node", it
is not able to join the cluster as this address is not visible externally.
Master node is in a different network. Could someone suggest how can I
specifically set the publish address for the logstash process? I know this
option is available for the elastic search processes in its config file
(elasticsearch.yml) but not aware of how to set this for the logstash
process.

Thanks
Sijo Mathew

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ec56feca-62db-49e5-8e50-a29880cc3da9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Danilo Gimenez Ramos) #3

Now I understand!

I put the bind_host setting on the output section, and now it is working!

An excerpt of my logstash.conf:
output {
if "127.0.0.1" not in [message] {
elasticsearch {
host => "elasticsearch-server"
index => "logstash-haproxy-bsa-provserpro-%{+YYYY.MM.dd}"
cluster => "elasticsearch-diretorio"
bind_host => "this-logstash-server"
}
}
}

Thanks


(system) #4