Setting Up an Advanced Logstash Pipeline


(Architha) #1

Hi All,

I am new to Logstash and i was referring to the document on Setting Up an Advanced Logstash Pipeline (link:https://www.elastic.co/guide/en/logstash/current/advanced-pipeline.html#advanced-pipeline)
I have done the same way as it was mentioned in the doc. But when i try a test query to Elasticsearch based on the fields created by the grok filter plugin , i get the following as output :

Please provide feedback on this issue. Thanks in Advance!


(Mark Walkom) #2

Can you paste the text, not a screenshot. It's a lot easier to read.


(Architha) #3

Sure !
Here is the text :


C:\Users\ajuttu1>curl -XGET "localhost:9200/logstash-2016.01.06/_search?q=respon
se=200"
{"error":{"root_cause":[{"type":"index_not_found_exception","reason":"no such in
dex","resource.type":"index_or_alias","resource.id":"logstash-2016.01.06","index
":"logstash-2016.01.06"}],"type":"index_not_found_exception","reason":"no such i
ndex","resource.type":"index_or_alias","resource.id":"logstash-2016.01.06","inde
x":"logstash-2016.01.06"},"status":404}


(Mark Walkom) #4

As it says, the index doesn't exist.
Have you checked what exists in ES?


(Architha) #5

When i verify my configuration , the following is the output :

C:\logstash-2.1.1\bin>logstash -f first-pipeline.conf --configtest
io/console not supported; tty will not be manipulated
Configuration OK


And then i started Logstash :
C:\logstash-2.1.1\bin>logstash -f first-pipeline.conf
io/console not supported; tty will not be manipulated
Settings: Default filter workers:1
Logstash startup completed


(Mark Walkom) #6

Right, but did you put anything in ES?

Use https://www.elastic.co/guide/en/elasticsearch/reference/2.1/cat-indices.html


(system) #8