Setup cluster on windows 2012r2


#1

hi,

i can't seem to get the cluster to form when i installed elasticsearch I have no issues getting it to run on a debian, (dont say it I have to run windows in production!)

I've changed the elasticsearch.yml files on the nodes as follows

node 1

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: SD-ELK

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

node.name: node-1

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

node 2

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: SD-ELK

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

node.name: node-2

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

node 3

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

cluster.name: SD-ELK

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

node.name: node-3

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

i've restarted all the nodes

is there anything in this section i need to be aware of?

---------------------------------- Various -----------------------------------

Disable starting multiple nodes on a single system:

#node.max_local_storage_nodes: 1

Require explicit names when deleting indices:

#action.destructive_requires_name: true


(Magnus B├Ąck) #2

Multicast discovery was disabled by default in ES 2.0 so your unicast discovery configuration needs to point to the other cluster nodes. Also make sure that ES listens to non-loopback interfaces (network.host option).


(system) #3