Setup seems to be not configuring indexes correctly?


(Kurtis Rainbolt Greene) #1

So I have logstash, elasticsearch, kibana, an apm server, an apm client, and an apm RUM client all running with the correct settings however when I click the "Setup Kibana" and attempt to view transaction details:

First, it defaults to the default index which is not the apm index. Feels strange since the system should know the right index.

Second, no results turn up:

Finally, when I expand the search window to 24hrs I get this error message:

I haven't done anything strange to my setup, I'm using the official docker images. Also, to be clear, I know how to solve the individual issue, but this feels like something I shouldn't have to drop into to fix since 5.X.Y worked just fine?


(Søren Louv Jansen) #2

Hi Kurtis,

Sorry to hear about the bugs you are running into. What version of Kibana and APM Server are you using, and what steps do you take to resolve the error message that shows up when expanding the window in Discover?


(Søren Louv Jansen) #3

Hi again,

After taking a closer look, I think you are missing the index template.

Loading index template automatically
The index template should have been created automatically but you might have disabled this in the apm-server.yml config file.
Read more about how the index template is automatically loaded: https://www.elastic.co/guide/en/apm/server/current/configuration-template.html

Loading index template manually
To load the index template manually, please run:

apm-server setup --template

Read more about loading the index template manually here:
https://www.elastic.co/guide/en/apm/server/current/_manually_loading_template_configuration.html


(Gil Raphaelli) #4

In addition to what @sqren provided, you should find https://www.elastic.co/blog/how-to-send-data-through-logstash-or-kafka-from-elastic-apm useful for guidance on using apm-server with logstash.