Setup.template.enabled: false. not work for disable default mapping

filebeat version 7.1.1.
I set

setup.template.enabled: false.

but there are still other fields like network.* in my index. And after I set my own template, the template is used, but still certain fields in my index.

Just set "setup.template.enabled: false. ":


After set

setup.ilm.enabled: false
setup.template.name: "web"
setup.template.fields: "fields.yml"
setup.template.pattern: "nginx*"
setup.template.enable: false

and I set fields.yml to empty.
The result still like before.
That is too many fields, make nonsense

Welcome to our community! :smiley:

This is no longer supported and is EOL. Please upgrade.

What version of Elasticsearch are you using?