Shield 2 beta on previous versions of ES

security

(Bobby Hubbard) #1

Wondering if the new version of Shield announced today with field-level authorization will be available on earlier versions of Elasticsearch (specifically 1.7x)


(Steve Kearns) #2

Hi Bobby,

The new Field and Document-level security in Shield will only be available in Shield 2.0+, which works with ES 2.0+. Going forward, you will notice that the Shield/Watcher versions will be tied to the ES versions, making the compatibility matrix significantly easier!

Thanks,
Steve


(Bobby Hubbard) #3

thanks


(system) #4