Slow to stop metricbeat Windows service

Hello,

I'm installing metricbeat as a Windows service. I'm not using the supplied powershell files but rather doing it via WinSVC in C/C++. This start up and runs fine. When I want to update the files I'm stopping the service, then copying the new files over and starting again.

The issue I'm seeing is that I can't overwrite metricbeat.exe for up to 30 seconds after requesting the service to stop. I'm just launching the service with the -c argument, metricbeat.yml is below:

metricbeat.config.modules:
path: ${path.config}/modules.d/*.yml
reload.enabled: false
reload.period: 1m
setup.template.settings:
index.number_of_shards: 1
index.codec: best_compression
setup.kibana: ~
output.logstash:
hosts:
- 10.0.4.74:5044
processors:

  • add_host_metadata:
    geo:
    name: 10.0.5.103
    continent_name: Europe
    country_iso_code: GBR
    netinfo.enabled: true
  • add_fields:
    fields:
    sport: S
    competition: C
    location: L
    metricbeat.modules:
  • module: system
    metricsets:
    • cpu
    • memory
    • network
    • process
    • process_summary
    • uptime
    • socket_summary
    • core
    • diskio
    • filesystem
      enabled: true
      period: 20s
      processes: [.*]
      cpu.metrics: [percentages]
      core.metrics: [percentages]

Is there something I'm missing or would it be expected to take this long before being fully shut down?

Thanks.

@tomkirk Thanks for posting here! I don't see any known issues for this hmm.
Besides show to shut down, are you seeing slow on fetching data or slow to store data into Elasticsearch?