Slowlog not populating after deletion


(Tim Hopper) #1

This morning, I enabled slowlogs on a bunch of indices in my cluster by
issuing something like this
https://gist.github.com/tdhopper/a44cc4200b9c09aea389. Because I set the
threshold at 0 and we're doing lots of reads and writes, I got large logs
rather quickly. I decided to raise the thresholds and delete the logs
manually from all four machines on my cluster; I did this without
restarting the cluster. After doing this, no new *slowlog.log files were
created. I tried 'touch'ing the appropriate paths, but those files were not
populated.

I have since set the slowlog thresholds manually in my ElasticSearch.yml
file

index.search.slowlog.threshold.query.warn: 10s
index.search.slowlog.threshold.query.info: 5s
index.search.slowlog.threshold.query.debug: 2s
index.search.slowlog.threshold.query.trace: 0s
index.search.slowlog.threshold.fetch.warn: 10s
index.search.slowlog.threshold.fetch.info: 5s
index.search.slowlog.threshold.fetch.debug: 2s
index.search.slowlog.threshold.fetch.trace: 0s
index.indexing.slowlog.threshold.index.warn: 10s
index.indexing.slowlog.threshold.index.info: 5s
index.indexing.slowlog.threshold.index.debug: 2s
index.indexing.slowlog.threshold.index.trace: 0s

and restarted the cluster. The log files still were not populated.

I again issued a curl command to set the thresholds to 0ms, and I also set
'additivity.index.search.slowlog' and 'additivity.index.indexing.slowlog'
to 'true' for the cluster (though I'm not entirely clear on what those do).
Still no logs. I have also tried fiddling with the log level with a command
like this https://gist.github.com/tdhopper/2dc0d2aa039f3dd598ab.

I've uncovered two
http://stackoverflow.com/questions/23195280/elasticsearch-slow-log-wont-write-to-log-file
SO questions
http://stackoverflow.com/questions/23899327/elasticsearch-wont-log-slow-queries-anymore
that seem to have similar problems that have not been resolved.

Have I done something wrong that is preventing these logs from appearing?

I am using 1.3.0.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54d753c1-e9a5-4116-ac5c-0c8edd3a392b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Tim Hopper) #2

We added another node to our cluster yesterday, and its slowlog immediately
started populating. Any idea how to get these populating again after
they've been deleted?

On Wednesday, August 13, 2014 3:45:45 PM UTC-4, Tim Hopper wrote:

This morning, I enabled slowlogs on a bunch of indices in my cluster by
issuing something like this
https://gist.github.com/tdhopper/a44cc4200b9c09aea389. Because I set
the threshold at 0 and we're doing lots of reads and writes, I got large
logs rather quickly. I decided to raise the thresholds and delete the logs
manually from all four machines on my cluster; I did this without
restarting the cluster. After doing this, no new *slowlog.log files were
created. I tried 'touch'ing the appropriate paths, but those files were not
populated.

I have since set the slowlog thresholds manually in my ElasticSearch.yml
file

index.search.slowlog.threshold.query.warn: 10s
index.search.slowlog.threshold.query.info: 5s
index.search.slowlog.threshold.query.debug: 2s
index.search.slowlog.threshold.query.trace: 0s
index.search.slowlog.threshold.fetch.warn: 10s
index.search.slowlog.threshold.fetch.info: 5s
index.search.slowlog.threshold.fetch.debug: 2s
index.search.slowlog.threshold.fetch.trace: 0s
index.indexing.slowlog.threshold.index.warn: 10s
index.indexing.slowlog.threshold.index.info: 5s
index.indexing.slowlog.threshold.index.debug: 2s
index.indexing.slowlog.threshold.index.trace: 0s

and restarted the cluster. The log files still were not populated.

I again issued a curl command to set the thresholds to 0ms, and I also set
'additivity.index.search.slowlog' and 'additivity.index.indexing.slowlog'
to 'true' for the cluster (though I'm not entirely clear on what those do).
Still no logs. I have also tried fiddling with the log level with a command
like this https://gist.github.com/tdhopper/2dc0d2aa039f3dd598ab.

I've uncovered two
http://stackoverflow.com/questions/23195280/elasticsearch-slow-log-wont-write-to-log-file
SO questions
http://stackoverflow.com/questions/23899327/elasticsearch-wont-log-slow-queries-anymore
that seem to have similar problems that have not been resolved.

Have I done something wrong that is preventing these logs from appearing?

I am using 1.3.0.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1b7bdfa4-9e59-4f51-9b36-0b95ebd0a091%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Tim Hopper) #3

When the logs weren't populating initially, I created new log files with
touch. I deleted all those files and restarted my cluster, and ES created
new log files and they seem to be populating again.

On Friday, August 15, 2014 10:03:53 AM UTC-4, Tim Hopper wrote:

We added another node to our cluster yesterday, and its slowlog
immediately started populating. Any idea how to get these populating again
after they've been deleted?

On Wednesday, August 13, 2014 3:45:45 PM UTC-4, Tim Hopper wrote:

This morning, I enabled slowlogs on a bunch of indices in my cluster by
issuing something like this
https://gist.github.com/tdhopper/a44cc4200b9c09aea389. Because I set
the threshold at 0 and we're doing lots of reads and writes, I got large
logs rather quickly. I decided to raise the thresholds and delete the logs
manually from all four machines on my cluster; I did this without
restarting the cluster. After doing this, no new *slowlog.log files were
created. I tried 'touch'ing the appropriate paths, but those files were not
populated.

I have since set the slowlog thresholds manually in my ElasticSearch.yml
file

index.search.slowlog.threshold.query.warn: 10s
index.search.slowlog.threshold.query.info: 5s
index.search.slowlog.threshold.query.debug: 2s
index.search.slowlog.threshold.query.trace: 0s
index.search.slowlog.threshold.fetch.warn: 10s
index.search.slowlog.threshold.fetch.info: 5s
index.search.slowlog.threshold.fetch.debug: 2s
index.search.slowlog.threshold.fetch.trace: 0s
index.indexing.slowlog.threshold.index.warn: 10s
index.indexing.slowlog.threshold.index.info: 5s
index.indexing.slowlog.threshold.index.debug: 2s
index.indexing.slowlog.threshold.index.trace: 0s

and restarted the cluster. The log files still were not populated.

I again issued a curl command to set the thresholds to 0ms, and I also
set 'additivity.index.search.slowlog' and
'additivity.index.indexing.slowlog' to 'true' for the cluster (though I'm
not entirely clear on what those do). Still no logs. I have also tried
fiddling with the log level with a command like this
https://gist.github.com/tdhopper/2dc0d2aa039f3dd598ab.

I've uncovered two
http://stackoverflow.com/questions/23195280/elasticsearch-slow-log-wont-write-to-log-file
SO questions
http://stackoverflow.com/questions/23899327/elasticsearch-wont-log-slow-queries-anymore
that seem to have similar problems that have not been resolved.

Have I done something wrong that is preventing these logs from appearing?

I am using 1.3.0.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b1f39c58-0ba4-46da-906a-648e7a4b57f6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4