Snapshot is deleted automatically once I stop the docker container

(Hi, I am totally new to Elastic search, so sorry if this is very basic question.)

I had an Elasticsearch store running in background using docker.

I had used haystack to add some files and embeddings to it.
Then I created a snapshot of it and it was successful. But when I stopped the docker container and resumed it later, the snapshot was all gone!

Here was the response when I created the snapshot -

Here was the response when I tried to check snapshot status(before stopping the container) -

But then I stopped the container and resumed it and tried to check the snapshot and it was removed!

Did I make any error while creating the snapshot? How do I fix this? Please let me know.

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

Hi @dadoonet , thanks for the reply, I would update the post but I don't see a edit option in the post now. I also clicked on the "..." button just on the bottom right of the post but don't see any option to edit this.

Could you see the pencil button after having pressed on the 3 dots?

Hi, @dadoonet, no I can't see any pencil button after having pressed on the 3 dots. It was there just after I posted the question but now it's gone.