Snapshot to S3 compatible storage issue

ES 6.8.2
I have es cluster running.
When I try to create repo for s3 on minio
"type": "s3",
"settings": {
"bucket": "elasticsearch-backups",
"endpoint": "dns-name"

I get

"error" : {
"root_cause" : [
"type" : "repository_verification_exception",
"reason" : "[es_snapshot_s3] path is not accessible on master node"
"type" : "repository_verification_exception",
"reason" : "[es_snapshot_s3] path is not accessible on master node",
"caused_by" : {
"type" : "i_o_exception",
"reason" : "Unable to upload object [tests-KnN5zU85RRmeOSfqPWX1Pg/master.dat] using a single upload",
"caused_by" : {
"type" : "sdk_client_exception",
"reason" : "Unable to execute HTTP request: elasticsearch-backups.dns-name",
"caused_by" : {
"type" : "unknown_host_exception",
"reason" : "elasticsearch-backups.dns-name"
"status" : 500

because there is no elasticsearch-backups.dns-name dns A record

at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_91]
at [?:1.8.0_91]

Caused by: elasticsearch-backups.dns-name
at ~[?:1.8.0_91]
at ~[?:1.8.0_91]
at ~[?:1.8.0_91]

These is path_style_access option but I am not sure that it is available in 6.8.2 version ES.
Can someone clarify?

Hi @Sergey_Mucha

I'm afraid forcing path style access was only introduced in v7, see relevant PR here:

Could you maybe set an IP for the endpoint? That would be a workaround that would force the SDK to use path style access.

I set endpoint, not sure that I get what you mean for endpoint.

Sorry that was the worst possible typo :slight_smile: What I meant to write was that you should set an actual IP address for the endpoint, not a DNS name if that is possible.

:slight_smile: Ok. Now I get. hahaha. I used ip, but sometimes s3 will be with dnsname - it will require updates for s3 in case it use ssl(include ip address to alternative name).
Anyway thanks for clarification.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.