SnapshotMissingException attempting to restore s3 snapshot to different server

I've created the same snapshot repository on CLUSTER_1 and CLUSTER_2.

I took a full snapshot on CLUSTER_1 and attempted to run the restore command on CLUSTER_2.

The s3 bucket is correct, and the same on both. The base path is correct. I can see the files in the AWS console, but whenever I try to run the restore command I just get:

  "error" : "SnapshotMissingException[[s3full:201608151615] is missing]; nested: FileNotFoundException[Blob object [snapshot-201608151615] not found: The specified key does not exist. (Service: Amazon S3; Status Code: 404; Error Code: NoSuchKey; Request ID: 1B6FB23C4BC5940D)]; ",
  "status" : 404

I can see that file up in the s3 bucket in several locations. If anyone has any ideas as to why this isn't working, I would LOVE to hear them!

When I run this on the source server:

curl -XGET localhost:9200/_snapshot/s3full/_all?pretty

I get lots of lovely snapshots. But when I run it on the target server it's empty.

Am I just misunderstanding the way this should work?

Many thanks.

In the end I created a whole new snapshot in a whole new repo and then it worked. It must have been something wrong with the repo.