SOLVED: Memory Locking not working DEB/5.3.0

Installed 5.3.0 via DEB on Debian Stretch. I believe I have everything set right but I still get bootstrap failure for memlock:

root@stretch:~# grep memory /etc/elasticsearch/elasticsearch.yml
bootstrap.memory_lock: true
root@stretch:~# cat /etc/systemd/system/elasticsearch.service.d/elasticsearch.conf
root@stretch:~# grep elasticsearch /etc/security/limits.conf
elasticsearch soft memlock unlimited
elasticsearch hard memlock unlimited

but on start I get:

[2017-04-14T11:08:37,463][ERROR][o.e.b.Bootstrap          ] [kcs_test_vm_node] node validation exception
bootstrap checks failed
memory locking requested for elasticsearch process but memory is not locked

I tried systemctl daemon-reload just to make sure it was picking up LimitMEMLOCK from the elasticsearch.conf file for the unit, but that didn't change anything.

I assume I've either got some dumb syntax error somewhere or I'm forgetting something. Went over

a dozen times and checked threads on here. What am I messing up?

Aaaaaaaand it was OOM Killer. Someone revoke my nerd card. Turns out you can't lock 2GB of RAM on a VM with 2 GB.

So, move along, nothing to see here.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.