Span chart missing after apm-server stuck (and indexed were deleted)

Hi all

i've apm-server and django integration that worked till yesterday in our enviroment. we had some problem due to the queue is full probably beacuse due to the fact that the ELK stack stopped for a while. we solved it deleting the apm-* indexes that existed.

Now, evrerything started and works, expect the span chart that is missing in 3 of 4 projects that we monitor with APM.

How can I debug the problem or get why the chart is missing that data?

Hi @esseti! Is there any indication of an issue in the APM Server logs? I suspect something is going on with the apm*metric* index, perhaps this but the logs and config would help confirm.

In the apm-server there's no sign of problem. the configuration is the same in all projects. but for 1 it works, for the other 3 does not.

i tried to delete the index but no luck. it's just one service that sends data.

should i look into the log of the apm-agent rather than the server? i user django, where can i find some logs?

Any error logs in the agent should be in your app logs automatically under most common logging configs. But if you'd like to increase the verbosity of those logs you can check out our documentation here:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.