Specifying _nodes by attribute is broken


(Bdharrington7) #1

I'm trying to filter my nodes from the _nodes endpoint as in this example:

https://www.elastic.co/guide/en/elasticsearch/reference/1.7/cluster.html#cluster-nodes

Can anyone confirm that this actually works?

My setup consists of 3 master nodes (master = true, data = false), and 6 data nodes (master = false, data = true)

I have attributes coming back from my _nodes endpoint like so:

{
  "cluster_name": "gravity-es-prod03",
  "nodes": {
    "nu_34ob4RwCnaiDlD0vguA": {
      ...
      "version": "1.7.4",
      "build": "0d3159b",
      "attributes": {
        "http.enabled": "true",
        "data": "false",
        "master": "true"
      },

However, when I execute this: http://my-elasticsearch-url:9200/_nodes/master:false

I get no nodes back, but

http://my-elasticsearch-url:9200/_nodes/master:*false*

gets all master nodes back.


(Bdharrington7) #2

Ok so it looks like you can't really filter on the data or master attributes (maybe because it's boolean values?) but I added custom attributes:

node.type: client

and I can filter by that


(system) #3