Specifying a index in an ES 5.3 snapshot request does not seem to work


I'm using ES 5.3 with a cluster that has 9 data nodes, 3 master nodes and 28 indexes.

Snapshots are sent to s3.

The request I use to create the snapshot uses the following JSON body.

	"type": "s3",
	"settings": {
		"indices" : "my-march-logs",
		"ignore_unavailable" : true,
		"include_global_state" : false,
		"bucket" : "<my-bucket>",
		"region" :  "<my-region>",
		"endpoint" : "<my-endpoint>",
		"base_path": "<my-base-path>"

I would also like to point out that the base_path references a new s3 repo .

When I check on the progress of the snapshot I see all the indexes listed. I cannot share the response due to security concerns.

Is there some secret handshake that I'm missing? The my-march-logs index is only 77.5gb but the whole snapshot process is taking in excess of 12 hours for all 28 indexes. There is one index that is in excess of 700gb so I suspect that index is being included in the snapshot as well as the one indicated.

I would love to know what is actually happening and how to specify a specific index correctly.


Your request looks rather different from the one in the docs, in particular there's no settings nor should you specify the repository details here (bucket, region, etc.). The docs say to do this:

PUT /_snapshot/my_backup/snapshot_1
  "indices": "index_1,index_2",
  "ignore_unavailable": true,
  "include_global_state": false

Thank you! That was it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.