Start up Error on Kibana 6.x with Elastic x-Pack - Plugin is RED


(Mike Ricigiano) #1

I get this error when starting up Kibana 6.x with Elasticsearch 6.x + X-PACK.
I modified the kibana config file with suggestions from an older post but maybe some things have changed.

This was the old post I used:

Here is the errors on start up:

mricigli-mac:config ricig$ ../bin/kibana
log [19:12:40.973] [info][status][plugin:kibana@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.031] [info][status][plugin:elasticsearch@6.0.0-rc1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [19:12:41.055] [info][status][plugin:xpack_main@6.0.0-rc1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [19:12:41.078] [info][status][plugin:searchprofiler@6.0.0-rc1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [19:12:41.083] [info][status][plugin:ml@6.0.0-rc1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [19:12:41.139] [error][status][plugin:xpack_main@6.0.0-rc1] Status changed from yellow to red - Authentication Exception
log [19:12:41.140] [error][status][plugin:searchprofiler@6.0.0-rc1] Status changed from yellow to red - Authentication Exception
log [19:12:41.142] [error][status][plugin:ml@6.0.0-rc1] Status changed from yellow to red - Authentication Exception
log [19:12:41.142] [error][status][plugin:elasticsearch@6.0.0-rc1] Status changed from yellow to red - Authentication Exception
log [19:12:41.164] [error][status][plugin:tilemap@6.0.0-rc1] Status changed from uninitialized to red - Authentication Exception
log [19:12:41.167] [error][status][plugin:watcher@6.0.0-rc1] Status changed from uninitialized to red - Authentication Exception
log [19:12:41.190] [info][status][plugin:grokdebugger@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.194] [info][status][plugin:dashboard_mode@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.202] [error][status][plugin:logstash@6.0.0-rc1] Status changed from uninitialized to red - Authentication Exception
log [19:12:41.213] [error][status][plugin:upgrade@6.0.0-rc1] Status changed from uninitialized to red - Authentication Exception
log [19:12:41.252] [info][status][plugin:console@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.268] [info][status][plugin:metrics@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.502] [info][status][plugin:timelion@6.0.0-rc1] Status changed from uninitialized to green - Ready
log [19:12:41.506] [info][listening] Server running at http://127.0.0.1:5601
log [19:12:41.508] [error][status][ui settings] Status changed from uninitialized to red - Elasticsearch plugin is red


(Matt Bargar) #2

Looks like Kibana cannot authenticate with Elasticsearch. Have you set the password for all the built in users and updated the username and password in kibana.yml?


(Mike Ricigiano) #3

Yes I think, but must be doing something wrong. Here is the config file kibana I am using:

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address.

#server.host: "localhost"
server.host: "127.0.0.1"

Enables you to specify a path to mount Kibana at if you are running behind a proxy. This only affects

the URLs generated by Kibana, your proxy is expected to remove the basePath value before forwarding requests

to Kibana. This setting cannot end in a slash.

server.basePath: ""

The maximum payload size in bytes for incoming server requests.

server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

server.name: "Ricigliana"

The URL of the Elasticsearch instance to use for all your queries.

elasticsearch.url: "http://127.0.0.1:9200"

When this setting's value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

kibana.index: ".kibana"

The default application to load.

kibana.defaultAppId: "discover"

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

elasticsearch.username: "kibana"
elasticsearch.password: "kibanaadmin"

Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

Optional settings that provide the paths to the PEM-format SSL certificate and key files.

These files validate that your Elasticsearch backend uses the same key files.

#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

Optional setting that enables you to specify a path to the PEM file for the certificate

authority for your Elasticsearch instance.

#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

To disregard the validity of SSL certificates, change this setting's value to 'none'.

#elasticsearch.ssl.verificationMode: full

Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

the elasticsearch.requestTimeout setting.

#elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

must be a positive integer.

elasticsearch.requestTimeout: 30000

List of Kibana client-side headers to send to Elasticsearch. To send no client-side

headers, set this value to [] (an empty list).

#elasticsearch.requestHeadersWhitelist: [ authorization ]

Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.

#elasticsearch.customHeaders: {}

Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.

#elasticsearch.shardTimeout: 0

Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.

#elasticsearch.startupTimeout: 5000

Specifies the path where Kibana creates the process ID file.

#pid.file: /var/run/kibana.pid

Enables you specify a file where Kibana stores log output.

logging.dest: stdout

Set the value of this setting to true to suppress all logging output.

#logging.silent: false

Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

Set the value of this setting to true to log all events, including system usage information

and all requests.

logging.verbose: false

Set the interval in milliseconds to sample system and process performance

metrics. Minimum is 100ms. Defaults to 5000.

#ops.interval: 5000

The default locale. This locale can be used in certain circumstances to substitute any missing

translations.

#i18n.defaultLocale: "en"
#xpack.security.skipSslCheck: true
#xpack.security.useUnsafeSessions: true
#xpack.security.encryptionKey: "Something_at_least_32_characters"
xpack.security.enabled: false
xpack.monitoring.enabled: false
xpack.graph.enabled: false
xpack.reporting.enabled: false


(Matt Bargar) #4

To narrow down the problem, try submitting a query directly to ES as the kibana user to ensure the password is set up correctly.

I also noticed you have the security plugin disabled in kibana. If memory serves me correctly this should still work, but what happens if you enable it?


(Mike Ricigiano) #5

hi, sorry I am very new to ES, how do I submit a query to ES directly ?


(Mike Ricigiano) #6

Also what parameter in the kabani.yml config file! is the security plug in?


(Matt Bargar) #7

Try submitting a match_all query against the .kibana index for example. Submit the query as the kibana user. How you do this will depend on what authentication mechanism you have set up, most likely just basic auth.

xpack.security.enabled: false is the setting in kibana.yml I'm referring to.


(Mike Ricigiano) #8

Hi I tried
xpack.security.enabled: true

No effect, same results.

I tried the query and here is the result:
mricigli-mac:bin ricig$ curl -u, --user kibana:kibanaadmin -XGET 'localhost:9200/_search?pretty' -H 'Content-Type: application/json' -d'

{
"query": {
"match_all": {}
}
}
'
[2017-10-16T19:41:32,432][INFO ][o.e.x.s.a.AuthenticationService] [4mjFsbb] Authentication of [kibana] was terminated by realm [reserved] - failed to authenticate user [kibana]
{
"error" : {
"root_cause" : [
{
"type" : "security_exception",
"reason" : "failed to authenticate user [kibana]",
"header" : {
"WWW-Authenticate" : "Basic realm="security" charset="UTF-8""
}
}
],
"type" : "security_exception",
"reason" : "failed to authenticate user [kibana]",
"header" : {
"WWW-Authenticate" : "Basic realm="security" charset="UTF-8""
}
},
"status" : 401
}


(Matt Bargar) #9

Looks like the password for the kibana user isn't set up correctly. Try setting the password for the built in kibana user again and re-try that query afterward.


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.