Starting Kibana 5.0 with dev flag throws resource unavailable


(Konidala Satyanarayana) #1

Hi,
I seem to face a peculiar problem with kibana 5.0 GR. It seems to be working fine when I start the kibana server normally. But when I start with the dev flag it throws a 403 forbidden error and nothing more. log in console as follow(with verbose true):

log [15:10:28.095] [debug][connection][econnreset] ECONNRESET: Socket was closed by the client (probably the browser) before it could be read completely

Things were great when I was developing with the alpha versions, donot seem to understand the problem with the stable release.


thanks
S


(Thomas Neirynck) #2

hi @satya_fury,

what does your Kibana startup command look like?


(Konidala Satyanarayana) #3

It's cd bin && kibana -- dev


(Konidala Satyanarayana) #4

Is it only me who is facing the problem?

Regards
S


(Tim Sullivan) #5

I'm not sure this a supported way of running Kibana in dev mode. Typically, that process is:

  • clone the Kibana git repository
  • run npm install
  • run npm start

Running npm start from the kibana directory where you have the source code internally runs:

sh ./bin/kibana --dev

So the problem could be that you should not cd bin before running the kibana command.

The Contributing to Kibana documentation will tell you everything you need to know about running in a dev mode: https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md


(Konidala Satyanarayana) #6

I am using cd bin as I am developing in windows.


(Tim Sullivan) #7

Hi Satya,

The contributing guide I linked to above is also meant for developers who use Windows. Is there are specific problem you have when you use the commands given in the guide? Let us know what you get when you set up NVM and Node/NPM and then do:

nvm install "$(cat .node-version)"
npm install
npm run elasticsearch
npm start

Refer to the "Setting Up Your Development Environment" section: https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md#setting-up-your-development-environment


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.