Starting Kibana in dev mode in Windows not working


(Prachi Mishra) #1

In my local I have ELK Stack(5.4.3) Installed and its working fine .
On top of it I want to add some functionality so I am trying to do plugin development for the same.

I pulled the source code from https://github.com/elastic/kibana
giving the following command -
npm install
npm start

After giving npm start I am getting the following error

{"type":"log","@timestamp":"2017-08-09T09:42:27Z","tags":["status","plugin:elasticsearch@7.0.0-alpha1","error"],"pid":14116,"state":"red","message":"Status changed from yellow to red - This version of Kibana requires Elasticsearch v7.0.0-alpha1 on all nodes. I found the following incompatible nodes in your cluster: v5.4.3 @ 127.0.0.1:9200 (127.0.0.1)","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

I have Elasticsearch 5.4.3 up and running .
Even I tried to pull kibana 5.4.3 source code and tried starting it .It is also not working .
getting this message -

{"type":"log","@timestamp":"2017-08-09T09:55:44Z","tags":["status","plugin:elasticsearch@5.4.3","info"],"pid":14536,"state":"green","message":"Status changed from yellow to green - Kibana index ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

After several time I am getting the following error in browser -
{"statusCode":502,"error":"Bad Gateway","message":"read ECONNRESET"}

Can anyone suggest what I am doing wrong ?


(Spencer Alger) #2

To start a node of elasticsearch compatible with any branch of Kibana you can call npm run elasticsearch within the Kibana repository for your target version and it will download and run a local copy of elasticsearch great for development.

Also, about Kibana branches: we develop Kibana in the master branch, which is also the default branch that you checkout when you clone from Github. That branch will someday be released as Kibana 7, which is why the error message you see is talking about Elasticsearch 7. The same is true for the master branch of Elasticsearch.

When developing a Kibana plugin you have to choose which version of Kibana you want to target first. If you plan to deploy the plugin to production soon I would recommend developing against 5.5. We released 5.5.1 not that long ago, and will be moving on to 5.6 soon-ish. Upgrading your plugin from 5.5 to 5.6 shouldn't be that hard, but it will depend a lot on what integrations/extensions you are working with.

I also recommend using the kibana plugin template to get going, and that template's current version is only compatible with Kibana 5.5+, so there is another reason to start there.


(Prachi Mishra) #3

Thanks for your reply @spalger

I have pulled data from the following branch https://github.com/elastic/kibana and did

npm run elasticsearch inside the kibana repository as you suggested .Its working and I have also added the sample plugin Its working, however its very slow.

Could you please help me with the following queries -

  1. Lets say I want my production ELK stack on 5.5 then I have to start developing plugin in 5.5 version right ?If so please provide the git repository for 5.5 version. (Recently doing plugin development on the version 7.0.0-alpha1)

  2. I want to test my plugin with already indexed data I have created using logstash . Currently I have 5.4.3 vesion of lostash and if I am running it its showing incompatible version. Should I need to upgrade the lostash version ?

  3. The plugin development requirement I have posted here - Webservice call from Kibana dashboard . Please suggest if I am heading in right direction.


(Spencer Alger) #4
  1. this is correct, but you'll use the same git repository. You have to switch to the 5.5 branch of that repository. If you have the git repository cloned locally that will look like this:

    # make sure that "upstream" points to elastic/kibana repo
    git remote -v
    
    # if it doesn't, add it
    git remote add upstream https://github.com/elastic/kibana.git
     
    git fetch upstream 5.5
    git checkout -b 5.5
    git branch --set-upstream-to=upstream/5.5
    
    # always run npm install when pulling changes from github
    npm install
    
    # in the future, to get the latest changes
    git pull
    npm install
    
  2. If you checkout branch 5.5 as described above then just run npm run elasticsearch in the 5.5 branch and it will start a 5.5 elasticsearch node

  3. sounds like you're headed in the right direction, hope you enjoy the journey! Go ahead and open new topics if you have more questions, we don't want to get too off topic


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.