Static mapping error


(Giuseppe Merlo) #1

Hi everyone,

as title says, i'm trying to use the disable dynamic mapping setting. I able to disable dynamic mapping for a index that i want, before this index is created.

Then, i've used the command

curl -XPUT 'http://localhost:9220/anime/_mapping/Anime' -d '@/home/giuseppe/Scrivania/StdKibi/Anime.mapping'

and i created the mapping. In fact, if i check mapping with

curl -XGET 'http://localhost:9220/anime?pretty'

the answer is:

    { "anime" : {
        "aliases" : { },
        "mappings" : {
     "Anime" : {
        "properties" : {
             "name" : {
                "type" : "string",
                "index" : "not_analyzed"
                          }
                         }
             }
         },
          "settings" : {
             "index" : {
               "mapper" : {
                   "dynamic" : "false"
                        },
         "creation_date" : "1494235621018",
         "number_of_shards" : "5",
         "number_of_replicas" : "1",
         "uuid" : "tEZF5w71S2i5z9erXtKF8Q",
         "version" : {
                   "created" : "2040499"
        }
      }
   },
"warmers" : { }}}

Now, when i try to put my document, i get this error:
"type":"illegal_state_exception","reason":"trying to auto create mapping, but dynamic mapping is disabled"

Can anyone help me?

Thanks a lot!


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.