Stopword filter not working after reindex


#1

Is there any reason a newly created index, which is exactly the same as the original one, wouldn't be filtering out stopwords?

Reindexing locally like this:

POST _reindex
{
"source": {"index" : "data-live"},
"dest": {"index": "data-live2"}
}

Followed by:

POST data-live2/_forcemerge


(Nik Everett) #2

Reindexing doesn't copy the index settings and mapping. That is usually why things like this happen.


#3

The new index has the same settings and mapping, the only difference being: a new analyzer field was added in the new mapping.

Shouldn't reindexing still include the stopwords filter on the analyzer existing in both indices?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.