Strange behaviour of custom mapping.. Need guidance


(Bharvi Dixit-2) #1

Hi all,

I have created mapping according to my domain data. And using unique id
from one of the field from the source by setting path of _id="name of the
field to be used".
When i post the data in json format through curl command the id is
generated from the source but when i insert the data through java program,
id is generated randomly and not gets chosen fusing the path from source.

the other thing is i have defined a field as string type but when i pass an
integer data to it elasticsearch stores it in integer format without giving
any exception :frowning:
What can i do..??

Thanks in advance,
Bharvi Dixit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4857b82e-4b7d-41b7-8fe2-3abcac79b30a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

can you create a gist with the curl example and the java code, so we can
take a look? Maybe there is a glitch in the code, maybe there is a bug,
having an example for this would be great. See
http://www.elasticsearch.org/help

Thanks a lot!

--Alex

On Mon, Feb 3, 2014 at 7:40 PM, Bharvi Dixit bharvidixit@gmail.com wrote:

Hi all,

I have created mapping according to my domain data. And using unique id
from one of the field from the source by setting path of _id="name of the
field to be used".
When i post the data in json format through curl command the id is
generated from the source but when i insert the data through java program,
id is generated randomly and not gets chosen fusing the path from source.

the other thing is i have defined a field as string type but when i pass
an integer data to it elasticsearch stores it in integer format without
giving any exception :frowning:
What can i do..??

Thanks in advance,
Bharvi Dixit

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4857b82e-4b7d-41b7-8fe2-3abcac79b30a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8eG%3Dx569oQ_5_zczG6kk3RNAsC-PoBWeh5-QihbEZ9TA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3