Stuck in "Kibana server is not ready yet" for last 24 hr kibana not loading

I'm running ELK ver 7.1 with kibana.yml that looks like

server.port: 5601
server.host: 0.0.0.0
elasticsearch.hosts: ["https://illumin8.inboxbiz.com:9200"]
elasticsearch.username: "elastic"
elasticsearch.password: "elk#123"

server.ssl.enabled: true
server.ssl.key: /root/elasticsearch-7.1.1/config/cert/wildcard_inboxbiz_com.key
server.ssl.certificate: /root/elasticsearch-7.1.1/config/cert/wildcard_inboxbiz_com.crt
elasticsearch.ssl.certificate: /root/elasticsearch-7.1.1/config/cert/wildcard_inboxbiz_com.crt
elasticsearch.ssl.key: /root/elasticsearch-7.1.1/config/cert/wildcard_inboxbiz_com.key

and elasticsearch.yml is:-

http.port: 9200
network.host: 10.27.0.4
network.publish_host: 10.27.0.4
discovery.seed_hosts: ["illumin8"]
cluster.initial_master_nodes: ["illumin8"]
xpack.security.enabled: true
#xpack.security.http.ssl.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.key: cert/wildcard_inboxbiz_com.key
xpack.security.transport.ssl.certificate: cert/wildcard_inboxbiz_com.crt
xpack.security.transport.ssl.certificate_authorities: [ "cert/DigiCertCA2.pem" ]

error on elastic-search cluster is

Using REST wrapper from plugin org.elasticsearch.xpack.security.Security
[2019-08-10T08:55:08,952][INFO ][o.e.d.DiscoveryModule ] [illumin8] using discovery type [zen] and seed hosts providers [settings]
[2019-08-10T08:55:10,009][INFO ][o.e.n.Node ] [illumin8] initialized
[2019-08-10T08:55:10,010][INFO ][o.e.n.Node ] [illumin8] starting ...
[2019-08-10T08:55:10,143][INFO ][o.e.t.TransportService ] [illumin8] publish_address {10.27.0.4:9300}, bound_addresses {10.27.0.4:9300}
[2019-08-10T08:55:10,151][INFO ][o.e.b.BootstrapChecks ] [illumin8] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2019-08-10T08:55:10,159][INFO ][o.e.c.c.Coordinator ] [illumin8] cluster UUID [YB1-EZrBRju-sm1h_74oUA]
[2019-08-10T08:55:10,430][INFO ][o.e.c.s.MasterService ] [illumin8] elected-as-master ([1] nodes joined)[{illumin8}{tJl3X-bPRp62gGp_Gtj8UQ}{ug6JR nnhQgKiHE03PebdMg}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058152960, xpack.installed=true, ml.max_open_jobs=20} elect leader, BECOME_MASTER TASK_, FINISH_ELECTION], term: 123, version: 3436, reason: master node changed {previous , current [{illumin8}{tJl3X-bPRp62gGp_Gtj8UQ}{ug6JRnnhQ gKiHE03PebdMg}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058152960, xpack.installed=true, ml.max_open_jobs=20}]}
[2019-08-10T08:55:12,205][INFO ][o.e.c.s.ClusterApplierService] [illumin8] master node changed {previous , current [{illumin8}{tJl3X-bPRp62gGp_Gtj 8UQ}{ug6JRnnhQgKiHE03PebdMg}{10.27.0.4}{10.27.0.4:9300}{ml.machine_memory=4058152960, xpack.installed=true, ml.max_open_jobs=20}]}, term: 123, versi on: 3436, reason: Publication{term=123, version=3436}
[2019-08-10T08:55:12,266][INFO ][o.e.h.AbstractHttpServerTransport] [illumin8] publish_address {10.27.0.4:9200}, bound_addresses {10.27.0.4:9200}
[2019-08-10T08:55:12,267][INFO ][o.e.n.Node ] [illumin8] started
[2019-08-10T08:55:12,600][INFO ][o.e.c.s.ClusterSettings ] [illumin8] updating [xpack.monitoring.collection.enabled] from [false] to [true]
[2019-08-10T08:55:13,194][INFO ][o.e.l.LicenseService ] [illumin8] license [8265ae0a-a6fa-4283-88d6-40ec8f08cc3a] mode [basic] - valid
[2019-08-10T08:55:13,205][INFO ][o.e.g.GatewayService ] [illumin8] recovered [46] indices into cluster_state
[2019-08-10T08:55:15,046][INFO ][o.e.x.w.WatcherService ] [illumin8] reloading watcher, reason [new local watcher shard allocation ids], cancelled [0] queued tasks
[2019-08-10T08:55:24,020][INFO ][o.e.c.r.a.AllocationService] [illumin8] Cluster health status changed from [RED] to [YELLOW] (reason: [shards start

Problem solved .....
with
elasticsearch.hosts: ["http://10.27.0.4:9200"]

was https, i got confused as most examples https://www.elastic.co/guide/en/kibana/current/configuring-tls.html
it mentioned https which was misleading since i m using all in one ELK is one single host.

Also, I'm not aware of any config on elasticsearch side to have it receive traffic as "https"?