Why Kibana server is not ready yet

I got "Kibana server is not ready yet" message. It happened after i was trying to enable TLS on the HTTP layer in Elasticsearch.
i added following lines to kibana.yml and restarted services. I reverted all settings back but its not working anymore.

xpack.encryptedSavedObjects.encryptionKey: "some32charlongkey"
xpack.security.encryptionKey: "some32charlongkey"
elasticsearch.ssl.certificateAuthorities: ["/etc/kibana/elasticsearch-ca.pem"]
elasticsearch.ssl.verificationMode: certificate

When I checked kibana.stderr, it says port 5601 is already in use (so I once set server.port to 5602 but it didn’t help. And we have another server with same error that runs without prb) We use nginx and it redirects 80/443 to 5601 so i connect to

i tried to stop nginx and connect to but nothing happened.

curl -XGET localhost:9200 -u elastic
command output looks ok. 

netstat -tnlp

systemctl status kibana
it says

lsof -i -nP | grep LISTEN
it says

This error message is telling you that Kibana can't connect to your Elasticsearch nodes. Kibana can't start until it has a persistent connection to Elasticsearch.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.