Stuck in loading Kibana...!

Hello
When I start the Kibana service (bin/kibana) it stuck somewhere which the last line is:

[warning][plugins][reporting] Enabling the Chromium sandbox provides an additional layer of protection.

And also I can`t access to it web(localhost:5602 --> changed the default port)
Other services like elasticsearch and logstash are up and work correctly...

But unfortunately, I can`t run the kibana :frowning: :worried:
Can anybody help me please?!?

Please don't post pictures of text, they are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

1 Like

Sure I apologize

root-7293f4185198$:/usr/share/kibana$ bin/kibana --allow-root
  log   [08:37:36.374] [warning][plugins-discovery] Expect plugin "id" in camelCase, but found: beats_management
  log   [08:37:36.398] [warning][plugins-discovery] Expect plugin "id" in camelCase, but found: triggers_actions_ui
[BABEL] Note: The code generator has deoptimised the styling of /usr/share/kibana/x-pack/plugins/canvas/server/templates/pitch_presentation.js as it exceeds the max of 500KB.
  log   [08:39:00.238] [info][plugins-service] Plugin "visTypeXy" is disabled.
  log   [08:39:00.240] [info][plugins-service] Plugin "auditTrail" is disabled.
  log   [08:39:02.356] [warning][config][deprecation] Setting [elasticsearch.username] to "kibana" is deprecated. You should use the "kibana_system" user instead.
  log   [08:39:02.357] [warning][config][deprecation] Config key [monitoring.cluster_alerts.email_notifications.email_address] will be required for email notifications to work in 8.0."
  log   [08:39:02.357] [warning][config][deprecation] Setting [monitoring.username] to "kibana" is deprecated. You should use the "kibana_system" user instead.
  log   [08:39:02.600] [info][plugins-system] Setting up [92] plugins: [taskManager,licensing,observability,globalSearch,globalSearchProviders,code,usageCollection,ossTelemetry,telemetryCollectionManager,teleme                       try,telemetryCollectionXpack,kibanaUsageCollection,newsfeed,mapsLegacy,kibanaLegacy,translations,timelion,share,legacyExport,esUiShared,charts,bfetch,expressions,data,home,cloud,apmOss,console,consoleExtensions                       ,searchprofiler,painlessLab,grokdebugger,management,upgradeAssistant,licenseManagement,watcher,indexPatternManagement,advancedSettings,fileUpload,dataEnhanced,savedObjects,visualizations,visualize,visTypeVislib                       ,visTypeVega,visTypeTimeseries,visTypeTimelion,features,security,snapshotRestore,reporting,enterpriseSearch,encryptedSavedObjects,ingestManager,indexManagement,rollup,remoteClusters,crossClusterReplication,inde                       xLifecycleManagement,beats_management,transform,ingestPipelines,maps,graph,canvas,visTypeTagcloud,visTypeTable,visTypeMarkdown,visTypeMetric,tileMap,regionMap,inputControlVis,discover,discoverEnhanced,dashboard                       ,lens,dashboardMode,savedObjectsManagement,spaces,lists,eventLog,actions,case,alerts,alertingBuiltins,ml,securitySolution,infra,monitoring,logstash,apm,uptime]
  log   [08:39:02.936] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionK                       ey in kibana.yml
  log   [08:39:02.939] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
  log   [08:39:02.999] [warning][config][plugins][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.reporting.encrypti                       onKey in kibana.yml
  log   [08:39:03.006] [warning][config][encryptedSavedObjects][plugins] Generating a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to decrypt encrypted saved objects attributes after res                       tart, please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml
  log   [08:39:03.014] [warning][ingestManager][plugins] Fleet APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey                        in kibana.yml.
  log   [08:39:03.142] [warning][actions][actions][plugins] APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in                        kibana.yml.
  log   [08:39:03.173] [warning][alerting][alerts][plugins][plugins] APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encrypt                       ionKey in kibana.yml.
  log   [08:39:03.357] [info][monitoring][monitoring][plugins] config sourced from: production cluster
  log   [08:39:03.441] [warning][config][plugins][reporting] Chromium sandbox provides an additional layer of protection, but is not supported for Linux Debian 9.13 OS. Automatically setting 'xpack.reporting.ca                       pture.browser.chromium.disableSandbox: true'.
  log   [08:39:03.843] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...
  log   [08:39:03.844] [info][savedobjects-service] Starting saved objects migrations
  log   [08:39:03.918] [info][plugins-system] Starting [92] plugins: [taskManager,licensing,observability,globalSearch,globalSearchProviders,code,usageCollection,ossTelemetry,telemetryCollectionManager,telemetr                       y,telemetryCollectionXpack,kibanaUsageCollection,newsfeed,mapsLegacy,kibanaLegacy,translations,timelion,share,legacyExport,esUiShared,charts,bfetch,expressions,data,home,cloud,apmOss,console,consoleExtensions,s                       earchprofiler,painlessLab,grokdebugger,management,upgradeAssistant,licenseManagement,watcher,indexPatternManagement,advancedSettings,fileUpload,dataEnhanced,savedObjects,visualizations,visualize,visTypeVislib,v                       isTypeVega,visTypeTimeseries,visTypeTimelion,features,security,snapshotRestore,reporting,enterpriseSearch,encryptedSavedObjects,ingestManager,indexManagement,rollup,remoteClusters,crossClusterReplication,indexL                       ifecycleManagement,beats_management,transform,ingestPipelines,maps,graph,canvas,visTypeTagcloud,visTypeTable,visTypeMarkdown,visTypeMetric,tileMap,regionMap,inputControlVis,discover,discoverEnhanced,dashboard,l                       ens,dashboardMode,savedObjectsManagement,spaces,lists,eventLog,actions,case,alerts,alertingBuiltins,ml,securitySolution,infra,monitoring,logstash,apm,uptime]
  log   [08:39:03.921] [info][plugins][taskManager][taskManager] TaskManager is identified by the Kibana UUID: 43930198-b99d-46a0-94f1-8c454123e37c
  log   [08:39:05.706] [info][plugins][watcher] Your basic license does not support watcher. Please upgrade your license.
  log   [08:39:05.710] [info][crossClusterReplication][plugins] Your basic license does not support crossClusterReplication. Please upgrade your license.
  log   [08:39:05.740] [info][kibana-monitoring][monitoring][monitoring][plugins] Starting monitoring stats collection
  log   [08:39:06.565] [info][status][plugin:kibana@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.573] [info][status][plugin:elasticsearch@7.9.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log   [08:39:06.574] [info][status][plugin:elasticsearch@7.9.1] Status changed from yellow to green - Ready
  log   [08:39:06.577] [info][status][plugin:xpack_main@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.589] [info][status][plugin:monitoring@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.592] [info][status][plugin:spaces@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.594] [info][status][plugin:security@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.597] [info][status][plugin:beats_management@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.640] [info][status][plugin:apm_oss@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.647] [info][status][plugin:console_legacy@7.9.1] Status changed from uninitialized to green - Ready
  log   [08:39:06.660] [info][listening] Server running at http://localhost:5602
  log   [08:39:07.658] [info][server][Kibana][http] http server running at http://localhost:5602
  log   [08:39:09.000] [warning][plugins][reporting] Enabling the Chromium sandbox provides an additional layer of protection.

Thanks!

Can you post a screenshot of your browser when it's loading/loaded localhost:5602?

I connected to 172.18.223.235 via mobaXterm (localhost => 172.18.223.235)

Looks like Kibana is up and running. From Logs.
Can you ssh login to instance server and run
curl http://locahost:5602/login

Thank you for your response
The result is too long...
some head -n 26 is:
'''

Elastic
    @font-face {
      font-family: 'Inter UI';
      font-style: normal;
      font-weight: 100;
      src: url('/ui/fonts/inter_ui/Inter-UI-Thin-BETA.woff2') format('woff2'), url('/ui/fonts/inter_ui/Inter-UI-Thin-BETA.woff') format('woff');
    }

    @font-face {
      font-family: 'Inter UI';
      font-style: italic;
      font-weight: 100;
      src: url('/ui/fonts/inter_ui/Inter-UI-ThinItalic-BETA.woff2') format('woff2'), url('/ui/fonts/inter_ui/Inter-UI-ThinItalic-BETA.woff') format('woff');
    }

    @font-face {
      font-family: 'Inter UI';
      font-style: normal;
      font-weight: 200;
      src: url('/ui/fonts/inter_ui/Inter-UI-ExtraLight-BETA.woff2') format('woff2'), url('/ui/fonts/inter_ui/Inter-UI-ExtraLight-BETA.woff') format('woff');
    }

    @font-face {
      font-family: 'Inter UI';
      font-style: italic;
      font-weight: 200;
      src: url('/ui/fonts/inter_ui/Inter-UI-ExtraLightItalic-BETA.woff2') format('woff2'), url('/ui/fonts/inter_ui/Inter-UI-ExtraLightItalic-BETA.woff') format('woff');
    }

'''

and this is my Kibana configuration:
'''

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5602

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address.

server.host: "localhost"

Enables you to specify a path to mount Kibana at if you are running behind a proxy.

Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

server.name: "******"

The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["http://localhost:9200"]

When this setting's value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

#elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

#kibana.index: ".kibana"

The default application to load.

#kibana.defaultAppId: "home"

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

elasticsearch.username: "elastic"
elasticsearch.password: "*******"

Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

Optional settings that provide the paths to the PEM-format SSL certificate and key files.

These files are used to verify the identity of Kibana to Elasticsearch and are required when

xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.

#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

Optional setting that enables you to specify a path to the PEM file for the certificate

authority for your Elasticsearch instance.

#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

To disregard the validity of SSL certificates, change this setting's value to 'none'.

#elasticsearch.ssl.verificationMode: full

Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

the elasticsearch.requestTimeout setting.

#elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

must be a positive integer.

#elasticsearch.requestTimeout: 30000

List of Kibana client-side headers to send to Elasticsearch. To send no client-side

headers, set this value to (an empty list).

#elasticsearch.requestHeadersWhitelist: [ authorization ]

Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.

#elasticsearch.customHeaders: {}

Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.

#elasticsearch.shardTimeout: 30000

Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.

#elasticsearch.startupTimeout: 5000

Logs queries sent to Elasticsearch. Requires logging.verbose set to true.

#elasticsearch.logQueries: false

Specifies the path where Kibana creates the process ID file.

#pid.file: /var/run/kibana.pid

Enables you to specify a file where Kibana stores log output.

#logging.dest: stdout

Set the value of this setting to true to suppress all logging output.

#logging.silent: false

Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

Set the value of this setting to true to log all events, including system usage information

and all requests.

#logging.verbose: false

Set the interval in milliseconds to sample system and process performance

metrics. Minimum is 100ms. Defaults to 5000.

#ops.interval: 5000

Specifies locale to be used for all localizable strings, dates and number formats.

Supported languages are the following: English - en , by default , Chinese - zh-CN .

#i18n.locale: "en"
'''

Change your kibana.yml and use

server.host: "0.0.0.0"

Then try to access Kibana from your browser using IP adresse of your host

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

Thank you so much

Sure, I apologize... Thank you so much

Looking at curl response, we can see Kibana is up and running!
you need to check your connectivity from your computer and server ip.

Hello Farid,
First of all your default config contains localhost:9200 which means you can access the kibana only using an ssh tunnel from the phisical ip ( 172.18.x.x ) to 127.0.0.1 of the server. You can do that using mobaXTerm's tunnel feature. I would say great security allowing only localhost to connect to kibana but i guess that's not what you are looking for. In your case it is listening only from queries from itself not accepting from other source IP.

I would change that line in the config to
server.host: "172.18.x.x" ...so kibana would be accessible from outside the box and only on that interface.

Do you have kibana and elastic on the same box? If not change this line with the ip of the box hosting elastic db
elasticsearch.hosts: ["[http://ipoftheelasticbox:9200]

Server is not stuck, kibana is working, you are just not allowed to access it over 172.18.x.x interface. Localhost=127.0.0.1 and that's your problem

Hope this helps