Kibana service is not running it's waiting with “loading elastic”

When I try to run bin/kibana. I get the below message. When I check the localhost:5601.

Kibana is waiting "loading elastic" message.

How can i solve this problem ?

 log   [16:25:00.767] [info][plugins-service] Plugin "visTypeXy" is disabled.
  log   [16:25:00.864] [warning][config][deprecation] Config key [monitoring.cluster_alerts.email_notifications.email_address] will be required for email notifications to work in 8.0."
  log   [16:25:01.113] [info][plugins-system] Setting up [101] plugins: [....]
  log   [16:25:01.116] [info][plugins][taskManager] TaskManager is identified by the Kibana UUID: ..
  log   [16:25:01.359] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
  log   [16:25:01.609] [info][monitoring][monitoring][plugins] config sourced from: production cluster
  log   [16:25:01.830] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...
  log   [16:25:01.930] [info][savedobjects-service] Starting saved objects migrations
  log   [16:25:02.025] [info][plugins-system] Starting [101] plugins: [.....]
  log   [16:25:03.159] [info][listening] Server running at http://localhost:5601
  log   [16:25:03.891] [info][server][Kibana][http] http server running at http://localhost:5601
  log   [16:25:03.895] [info][plugins][watcher] Your basic license does not support watcher. Please upgrade your license.
  log   [16:25:03.899] [info][crossClusterReplication][plugins] Your basic license does not support crossClusterReplication. Please upgrade your license.
  log   [16:25:03.899] [info][kibana-monitoring][monitoring][monitoring][plugins] Starting monitoring stats collection
  log   [16:32:11.003] [warning][fetcher][plugins][telemetry] Error sending telemetry usage data. (FetchError: request to https://telemetry.elastic.co/xpack/v2/send failed, reason: connect ETIMEDOUT)

Thanks for answering

That looks ok.

What does Elasticsearch show in it's log?

When I check the localhost:5601.
Kibana is waiting "loading elastic" message.
Kibana is not openning

log [16:25:03.159] [info][listening] Server running at http://localhost:5601

it looks good. please try to stop and restart it again.

Can you please send output of elasticsearch server : http://localhost:9200

I tried to restart. When i curl to es, I get all the nodes and es cluster health is green. But the thing is es makes only one master nodes. But i ve specify five master nodes in elasticsearch.yml (node.master: true) and there is no error message but kibana is just waiting with "loading elastic"

Change your kibana.yml and use

server.host: "0.0.0.0"

Then try to access Kibana from your browser using IP adresse of your host

Can you please post your kibana.yml & elasticsearch.yml

The server-log seems OK . What happens? Does the loading screen never complete?

Can you try again and wait for a few minutes? The first time on startup Kibana needs to compile resources, which may take a while.

If the loading screen still does not disappear, look at the browser debugger (in Chrome, open this with Ctrl-Shift-J) and let me know what is in there. Also , Try first:

  • clear your browser-cache
  • restart Kibana
  • try to use another browser

If this still does not work, please post Kibana.yml & elasticsearch.yml file.

I have deleted all nodes and re-download elasticsearch and kibana so elasticsearch.yml and kibana.yml 's are default now. When I run "bin/elasticsearch", elasticsearch is running on 9200 then try to run kibana with "bin/kibana" it says kibana is running. When I check localhost:5601 it's waiting with "loading elastic".
Both doesn't give errors but gives some warning these are:
elasticsearch says "no discovery configuration found" but cluster status is green
kibana says "session cookies will be transmitted over insecure connection" , "saved objects encryptoion key is not set" , "chromium sandbox provides an additional layer of protection but is not supported for Linux CentOS 7.4

Please share Error screenshot also try to clear your browser-cache or use another browser