Kibana isn't being displayed in web browser

Hi all,

I have a problem with my Kibana.
Elastic Search and Kibana run well but kibana isn't loaded in web browser and it just shows white page at localhost:5602.

kibana console last messages:

before starting saved objects migrations...
log [07:33:34.180] [info][savedobjects-service] Starting saved objects migrations
log [07:33:34.256] [info][savedobjects-service] Creating index .kibana_task_manager_1.
log [07:33:34.261] [info][savedobjects-service] Creating index .kibana_1.
log [07:33:35.450] [info][savedobjects-service] Pointing alias .kibana_task_manager to .kibana_task_manager_1.
log [07:33:35.602] [info][savedobjects-service] Pointing alias .kibana to .kibana_1.
log [07:33:35.760] [info][savedobjects-service] Finished in 1504ms.
log [07:33:35.853] [info][savedobjects-service] Finished in 1602ms.
log [07:33:35.932] [info][plugins-system] Starting [96] plugins: [taskManager,licensing,globalSearch,globalSearchProviders,code,usageCollection,xpackLegacy,telemetryCollectionManager,telemetry,telemetryCollectionXpack,kibanaUsageCollection,securityOss,newsfeed,mapsLegacy,kibanaLegacy,translations,share,legacyExport,embeddable,uiActionsEnhanced,expressions,data,home,observability,cloud,console,consoleExtensions,apmOss,searchprofiler,painlessLab,grokdebugger,management,indexPatternManagement,advancedSettings,fileUpload,savedObjects,dashboard,visualizations,visTypeVega,visTypeTimelion,timelion,features,upgradeAssistant,security,snapshotRestore,enterpriseSearch,encryptedSavedObjects,ingestManager,indexManagement,remoteClusters,crossClusterReplication,indexLifecycleManagement,dashboardMode,beatsManagement,transform,ingestPipelines,maps,licenseManagement,graph,dataEnhanced,visTypeTable,visTypeMarkdown,tileMap,regionMap,inputControlVis,visualize,esUiShared,charts,lens,visTypeVislib,visTypeTimeseries,rollup,visTypeTagcloud,visTypeMetric,watcher,discover,discoverEnhanced,savedObjectsManagement,spaces,reporting,lists,eventLog,actions,case,alerts,stackAlerts,triggersActionsUi,ml,securitySolution,infra,monitoring,logstash,apm,uptime,bfetch,canvas]
log [07:33:35.937] [info][plugins][taskManager][taskManager] TaskManager is identified by the Kibana UUID: 109107f6-6270-4df6-90c1-0dc69ec51b65
log [07:33:36.442] [info][crossClusterReplication][plugins] Your basic license does not support crossClusterReplication. Please upgrade your license.
log [07:33:36.467] [info][plugins][watcher] Your basic license does not support watcher. Please upgrade your license.
log [07:33:36.471] [info][kibana-monitoring][monitoring][monitoring][plugins] Starting monitoring stats collection
log [07:33:37.297] [info][listening] Server running at http://localhost:5602
log [07:33:38.391] [info][server][Kibana][http] http server running at http://localhost:5602

I would appreciate it if anyone could help me solve my problem.

Thanks GOOOD! Fortunately my problem sovled :))

I changed all of "localhost" with exact ip address of ELK server in all config files like kibana.yml, elasticsearch.yml and logstash.yml. Also I add "discovery.type: single-node" in elasticsearch.yml.

3 Likes