Support.elastic.co has an invalid certificate

https://support.elastic.co is not secure. I do not want enter my credentials because the certificate is invalid.

I can see a valid certificate. Are you sure your browser and Os are up to date?

Could you share some screenshots?

Thanks for the reply, David. I'm on MacOS Catalina 10.15.7. I'm using Chrome Version 85.0.4183.121 (Official Build) (64-bit). I attached a screenshot of the error.

The cert is valid I just checked I chrome and FFox. I suspect perhaps you have an old cached certificate it was updated in June 2020. Perhaps try with incognito?

1 Like

Hi, Stephen, thanks for the reply. I tried removing all cached data from Chrome, and I tried opening support.elastic.co with Incognito. Both attempts failed.

I attached a screenshot showing the cert hasn't expired.Screen Shot 2020-10-07 at 10.35.08 AM

On Mac...

BTW I am also on MacOS Catalina 10.15.7

Have you looked into your Keychain Access to see if you have an old cert that needs to be cleaned out.

Do you work at a company that that filters all your traffic through a proxy?

Can you try from another machine?

Try the url from your mobile?

I will check internally with our support but if we had a bad cert we I suspect we would be flooded with calls which we AFAICT we are not as I looked through the internal channel.

Update : I have tried from 2 different macs and a mobile, none are showing a bad cert, I suspect it is something in your ecosystem.

Thanks, Stephen. I think you're correct about it being specific to my ecosystem. I'm able to access it without cert issues from another machine and on mobile.

I need to double check my Keychain Access and whether there is a proxy I'm unaware of.

@jwasserman BTW got a report of same thing from another user... curious if you have seen again...I am checking internally again...

UPDATE : Turns out there is something down deep / a bit esoteric with our SalesForce integration which we are the process of fixing.

Just thought I would follow up

Hi, Stephen. Thanks for the follow-up. I still see the issue when I check on my work machine behind VPN, and I have not changed anything on it from last time - I just ended up ignoring it and proceeding since the site works OK from elsewhere.

I can confirm it works on the same machine without VPN. So it might be related to that.