Synonym not working for some entry


(paul) #1

The synonym entries marked in yellow does not work When i search mit it
does not show any results but it works for other entries

ES version 0.90.0
Java Version "1.7.0_45"

my synonym .txt

russia, ussr, russian federation
fui, Florida International University
rate, rating ,rated
mit, mass
jkt, JKTyres

My setting and mapping file

{
"settings":{
"analysis":{
"analyzer":{
"synonym":{
"tokenizer":"whitespace",
"filter":[
"standard",
"lowercase",
"syns_filter"
]
}
},
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym"
}
}
}
},
"mappings":{
"home":{
"properties":{
"name":{
"type":"string",
"analyzer":"synonym"
}
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/05d67cdd-0c9c-4e2a-a9d4-97c48f912f7d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jun Ohtani) #2

Hi paul,

What kind of your document and query, you fail to search?

I think that “fui” and “jkt” synonym entries does not work, because “Florida International University” and “JKTyres” include UpperCase character.
Your filter chain has the synonym filter after the lowercase filter.
Your document data indexed all lowercase terms by your analyzer, but your query (ex: “jkt") expand “jkt” OR “JKTyres” by synonym filter.

However, I don’t know why “mlt” entry does not work, because “mit” entry is all lowercase character.

Does it make sense?

Regards,


Jun Ohtani
johtani@gmail.com
blog : http://blog.johtani.info
twitter : http://twitter.com/johtani

2013/12/14 22:24、paul のメール:

The synonym entries marked in yellow does not work When i search mit it does not show any results but it works for other entries

ES version 0.90.0
Java Version "1.7.0_45"

my synonym .txt

russia, ussr, russian federation
fui, Florida International University
rate, rating ,rated
mit, mass
jkt, JKTyres

My setting and mapping file

{
"settings":{
"analysis":{
"analyzer":{
"synonym":{
"tokenizer":"whitespace",
"filter":[
"standard",
"lowercase",
"syns_filter"
]
}
},
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym"
}
}
}
},
"mappings":{
"home":{
"properties":{
"name":{
"type":"string",
"analyzer":"synonym"
}
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/05d67cdd-0c9c-4e2a-a9d4-97c48f912f7d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(paul) #3

thank you for the response i will add "ignore_case":true and test

On Sat, Dec 14, 2013 at 7:33 PM, Jun Ohtani johtani@gmail.com wrote:

Hi paul,

What kind of your document and query, you fail to search?

I think that “fui” and “jkt” synonym entries does not work, because
“Florida International University” and “JKTyres” include UpperCase
character.
Your filter chain has the synonym filter after the lowercase filter.
Your document data indexed all lowercase terms by your analyzer, but your
query (ex: “jkt") expand “jkt” OR “JKTyres” by synonym filter.

However, I don’t know why “mlt” entry does not work, because “mit” entry
is all lowercase character.

Does it make sense?

Regards,


Jun Ohtani
johtani@gmail.com
blog : http://blog.johtani.info
twitter : http://twitter.com/johtani

2013/12/14 22:24、paul のメール:

The synonym entries marked in yellow does not work When i search mit it
does not show any results but it works for other entries

ES version 0.90.0
Java Version "1.7.0_45"

my synonym .txt

russia, ussr, russian federation
fui, Florida International University
rate, rating ,rated
mit, mass
jkt, JKTyres

My setting and mapping file

{
"settings":{
"analysis":{
"analyzer":{
"synonym":{
"tokenizer":"whitespace",
"filter":[
"standard",
"lowercase",
"syns_filter"
]
}
},
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym"
}
}
}
},
"mappings":{
"home":{
"properties":{
"name":{
"type":"string",
"analyzer":"synonym"
}
}
}
}
}

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/05d67cdd-0c9c-4e2a-a9d4-97c48f912f7d%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAO066G3FXzCZOutt0iMVo-3H9bnos_pHWP%3DLNhi86WtNe0L%3DkQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(paul) #4

Hi Jun,
Adding "ignore_case":true worked and for the "mit" there was some special
character between words a double space or something mit, mass marked in red when
i changed it to no space it worked. is there a specific format
for synonym file and what should be the character encoding.

On Saturday, 14 December 2013 19:33:21 UTC+5:30, Jun Ohtani wrote:

Hi paul,

What kind of your document and query, you fail to search?

I think that “fui” and “jkt” synonym entries does not work, because
“Florida International University” and “JKTyres” include UpperCase
character.
Your filter chain has the synonym filter after the lowercase filter.
Your document data indexed all lowercase terms by your analyzer, but your
query (ex: “jkt") expand “jkt” OR “JKTyres” by synonym filter.

However, I don’t know why “mlt” entry does not work, because “mit” entry
is all lowercase character.

Does it make sense?

Regards,


Jun Ohtani
joh...@gmail.com <javascript:>
blog : http://blog.johtani.info
twitter : http://twitter.com/johtani

2013/12/14 22:24、paul のメール:

The synonym entries marked in yellow does not work When i search mit it
does not show any results but it works for other entries

ES version 0.90.0
Java Version "1.7.0_45"

my synonym .txt

russia, ussr, russian federation
fui, Florida International University
rate, rating ,rated
mit, mass
jkt, JKTyres

My setting and mapping file

{
"settings":{
"analysis":{
"analyzer":{
"synonym":{
"tokenizer":"whitespace",
"filter":[
"standard",
"lowercase",
"syns_filter"
]
}
},
"filter":{
"syns_filter":{
"synonyms_path":"synonyms/synonym_country.txt",
"type":"synonym"
}
}
}
},
"mappings":{
"home":{
"properties":{
"name":{
"type":"string",
"analyzer":"synonym"
}
}
}
}
}

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/05d67cdd-0c9c-4e2a-a9d4-97c48f912f7d%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e3f99085-b34d-4636-8f37-46e85e2f2f3c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5