Taking more time in Elastic Search


(Arcadix Infotech Pvt.Ltd) #1

Hi

I have an index, which is having 4 records. But its taking more 700 milliseconds.
Note : index.max_result_window : 100000
when decreasing window size, time also
For each index number of records is different(some < 10, some > 50000), so how can i solve this problem??

Thanks
Aneesh L


(David Pilato) #2

I don't think it's related to index.max_result_window setting but to the size parameter you are putting in your search call.

And I think that you set it to "size": 100000. Am I right?

And I hope you remember what I wrote:


(Arcadix Infotech Pvt.Ltd) #3

Hi David Pilato

Is it possible to update index.max_result_window? Like I set it to 1000 and when adding a new data need to increment by 1(DynamicUpdate)

Thanks
Aneesh


(David Pilato) #4

Yes. But I'd not do that and I'd keep the default value as 10000.
Again, a normal user can not read IMO 10000 results.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.